summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-08-21 20:40:30 -0400
committerJean Lucas2018-08-21 20:40:30 -0400
commitff96562b417eb2f2c0249361c3e0904f2f185cb5 (patch)
tree3fef78f82ccd4dab6fd7e2868284a30caf900d40
downloadaur-ff96562b417eb2f2c0249361c3e0904f2f185cb5.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d21189307a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Aug 22 00:40:18 UTC 2018
+pkgbase = python-pyleri
+ pkgdesc = Left-right parse
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/transceptor-technology/pyleri
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/transceptor-technology/pyleri/archive/1.2.2.tar.gz
+ sha512sums = b0dcbd82b2a920336b2a6ab9f420f0599ebe49fcc53f8a50e206a83f458462dc950231beb91ef01329067715554a5efd44861bd99aa4e8dd5099e5c6aa60ec8e
+
+pkgname = python-pyleri
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c7c4e3cc8ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=python-pyleri
+pkgver=1.2.2
+pkgrel=1
+pkgdesc='Left-right parse'
+arch=(any)
+url=https://github.com/transceptor-technology/pyleri
+license=(MIT)
+depends=(python)
+makedepends=(python-setuptools)
+source=($url/archive/$pkgver.tar.gz)
+sha512sums=('b0dcbd82b2a920336b2a6ab9f420f0599ebe49fcc53f8a50e206a83f458462dc950231beb91ef01329067715554a5efd44861bd99aa4e8dd5099e5c6aa60ec8e')
+
+package() {
+ cd pyleri-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm 644 LICENSE.txt "$pkgdir"/usr/share/licenses/python-pyleri/LICENSE
+}