summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-06-10 18:22:48 +0300
committerViktor Drobot2020-06-10 18:22:48 +0300
commitd468be173ae1df9ab06246006b7cf9ed6e87d1da (patch)
treed6018a02d7af57ab04d76f95ce9f560df532a151
parent050319e9d9bd52563e4f47ebb0260ecaca30d0d5 (diff)
downloadaur-d468be173ae1df9ab06246006b7cf9ed6e87d1da.tar.gz
Small fixes for PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef9bd8a68f16..6e8aca5faba4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = python-pylibconfig2
pkgdesc = Pure python library for libconfig syntax
pkgver = 0.2.5
- pkgrel = 1
+ pkgrel = 2
url = http://pypi.python.org/pypi/pylibconfig2
arch = any
- license = GPLv3
- makedepends = python-setuptools
+ license = GPL3
depends = python
depends = python-pyparsing
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index 4ca65fdad69c..5d26b0b03b8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-_name='pylibconfig2'
-pkgname=python-$_name
+
+pkgname=python-pylibconfig2
+_name=${pkgname#python-}
pkgver=0.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="Pure python library for libconfig syntax"
-arch=('any')
+arch=(any)
url="http://pypi.python.org/pypi/${_name}"
-license=('GPLv3')
-makedepends=('python-setuptools')
-depends=('python' 'python-pyparsing')
-options=(!emptydirs)
-
+license=(GPL3)
+depends=(python python-pyparsing)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha256sums=('186bd2d88356036ac8770195c8a3e9bac3ccdb3b9e6ecf04be62c307760895c7')
+options=(!emptydirs)
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
package() {
cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}