summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2024-01-09 12:21:47 +0800
committerlilac2024-01-09 12:21:47 +0800
commit9a598bf14900fa32419f4663a06537481898c504 (patch)
treed6f2eb418b45797cc343ed5a16ccc0eb7979f9dd
parente69cc0da0be9e80bc5ff09d9baeb6422a2b79d16 (diff)
downloadaur-python-pylibjpeg.tar.gz
[lilac] updated to 2.0.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcab81ab5569..3662c5080767 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = python-pylibjpeg
pkgdesc = A Python framework for decoding JPEG images, with a focus on supporting pydicom
- pkgver = 1.4.0
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/pydicom/pylibjpeg
arch = any
license = MIT
- checkdepends = python-pytest
- makedepends = python-setuptools
- depends = python-pylibjpeg-openjpeg
- source = python-pylibjpeg-1.4.0.tar.gz::https://github.com/pydicom/pylibjpeg/archive/v1.4.0.tar.gz
- sha512sums = 316649c6caca151b92a2e3b7ffc9dcf87591ec8d9b4395ac1752bbd877181e732b6897c38c6866403c6556440fc834f3b99881a988b3466a55b124b3e13f0a08
+ makedepends = python-build
+ makedepends = python-flit-core
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-numpy
+ optdepends = python-pylibjpeg-libjpeg
+ optdepends = python-pylibjpeg-openjpeg
+ optdepends = python-pylibjpeg-rle
+ source = python-pylibjpeg-2.0.0.tar.gz::https://github.com/pydicom/pylibjpeg/archive/v2.0.0.tar.gz
+ sha512sums = c72342de7d6952a41712944fb223d0fb1b016bae1b49a835701bd5f3647d4982f194b4cdb5a9a18bc5f95ecebba03f65041b4a774753b4b8723571603da2d979
pkgname = python-pylibjpeg
diff --git a/PKGBUILD b/PKGBUILD
index 79db1784e217..8bdf978d33a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,40 @@
_pkgname=pylibjpeg
pkgname=python-pylibjpeg
-pkgver=1.4.0
+pkgver=2.0.0
pkgrel=1
pkgdesc='A Python framework for decoding JPEG images, with a focus on supporting pydicom'
arch=(any)
url='https://github.com/pydicom/pylibjpeg'
license=(MIT)
depends=(
- python-pylibjpeg-openjpeg
+ python-numpy
)
makedepends=(
- python-setuptools
+ python-build
+ python-flit-core
+ python-installer
+ python-wheel
)
-checkdepends=(
- python-pytest
+optdepends=(
+ python-pylibjpeg-libjpeg
+ python-pylibjpeg-openjpeg
+ python-pylibjpeg-rle
)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/pydicom/pylibjpeg/archive/v${pkgver}.tar.gz")
-sha512sums=('316649c6caca151b92a2e3b7ffc9dcf87591ec8d9b4395ac1752bbd877181e732b6897c38c6866403c6556440fc834f3b99881a988b3466a55b124b3e13f0a08')
+sha512sums=('c72342de7d6952a41712944fb223d0fb1b016bae1b49a835701bd5f3647d4982f194b4cdb5a9a18bc5f95ecebba03f65041b4a774753b4b8723571603da2d979')
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 "LICENCE.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rf "${pkgdir}${site_packages}/pylibjpeg/tests"
+ rm -rf "${pkgdir}${site_packages}/pylibjpeg/tools/tests"
}
# vim:set ts=2 sw=2 et: