summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2016-06-28 01:59:54 +0200
committerSven-Hendrik Haase2016-06-28 01:59:54 +0200
commit256048cca48c905abca9130acea34450c1bcdab1 (patch)
treed48c39bf67a5de7da101cf07a8b6a8fa2c163160
downloadaur-256048cca48c905abca9130acea34450c1bcdab1.tar.gz
Push python-pylint-common
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ef860c7d04b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pylint-common
+ pkgdesc = Pylint plugin for augmenting and improving error detection and analysis in the standard Python library
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/landscapeio/pylint-common
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/landscapeio/pylint-common/archive/0.2.2.tar.gz
+ md5sums = aaa0146cb8ca185849d6a111003c23e8
+
+pkgname = python-pylint-common
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a5c7c5204b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+_pkgname=pylint-common
+pkgname=python-pylint-common
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Pylint plugin for augmenting and improving error detection and analysis in the standard Python library"
+arch=('any')
+url="https://github.com/landscapeio/pylint-common"
+license=('GPL2')
+depends=('python')
+makedepends=('python-setuptools')
+source=(https://github.com/landscapeio/pylint-common/archive/${pkgver}.tar.gz)
+md5sums=('aaa0146cb8ca185849d6a111003c23e8')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}
+# vim:set ts=2 sw=2 et: