summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrazer2023-10-29 19:10:16 +0100
committerrazer2023-10-29 19:10:16 +0100
commitccd178c56ce56fe95ab1fab85675894c551724f1 (patch)
tree19018dea2a9570f441bcc2b04da89556a402e5b0
parent3e7e0ddf923a70b01096d51137a533e687d36b54 (diff)
downloadaur-ccd178c56ce56fe95ab1fab85675894c551724f1.tar.gz
version bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 794b41f35fb5..89fe4a36cf8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-pylint-django
pkgdesc = A Pylint plugin to help Pylint understand the Django web framework
pkgver = 2.5.5
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/landscapeio/pylint-django
arch = any
license = GPL2
makedepends = python-setuptools
makedepends = python-pylint-plugin-utils
depends = python
- source = https://pypi.io/packages/source/p/pylint-django/pylint-django-2.5.5.tar.gz
+ source = https://pypi.io/packages/source/p/pylint_django/pylint_django-2.5.5.tar.gz
sha256sums = 2f339e4bf55776958283395c5139c37700c91bd5ef1d8251ef6ac88b5abbba9b
pkgname = python-pylint-django
diff --git a/PKGBUILD b/PKGBUILD
index 6d0f7d4dee67..862cce35fa56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Razer <razer@neuf.fr>
pkgname=python-pylint-django
-_pypi_pkgname=pylint-django
+_pypi_pkgname=pylint_django
pkgver=2.5.5
-pkgrel=0
+pkgrel=1
pkgdesc="A Pylint plugin to help Pylint understand the Django web framework"
arch=('any')
url="https://github.com/landscapeio/pylint-django"
@@ -14,12 +14,12 @@ sha256sums=('2f339e4bf55776958283395c5139c37700c91bd5ef1d8251ef6ac88b5abbba9b')
build() {
cd "${_pypi_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pypi_pkgname}-${pkgver}"
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
- install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm644 -t "$pkgdir/usr/share/license/$pkgname" LICENSE
}
# vim:set ts=2 sw=2 et: