summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2016-06-28 02:04:28 +0200
committerSven-Hendrik Haase2016-06-28 02:04:28 +0200
commit839fe61730d155cf419610acdddffd786862f76f (patch)
tree6a204761371d086430077e76c667f842b93dc1ae
downloadaur-839fe61730d155cf419610acdddffd786862f76f.tar.gz
Push python-pylint-plugin-utils
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fccd541a3a26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pylint-plugin-utils
+ pkgdesc = Utilities and helpers for writing Pylint plugins
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/landscapeio/pylint-plugin-utils
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/landscapeio/pylint-plugin-utils/archive/0.2.3.tar.gz
+ md5sums = 392bdb012310a621242c17365b9947c5
+
+pkgname = python-pylint-plugin-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26b15b737903
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+_pkgname=pylint-plugin-utils
+pkgname=python-pylint-plugin-utils
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="Utilities and helpers for writing Pylint plugins"
+arch=('any')
+url="https://github.com/landscapeio/pylint-plugin-utils"
+license=('GPL2')
+depends=('python')
+makedepends=('python-setuptools')
+source=(https://github.com/landscapeio/pylint-plugin-utils/archive/${pkgver}.tar.gz)
+md5sums=('c09c298cc2b5f1af0831edf7455228e7')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}
+# vim:set ts=2 sw=2 et: