summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Pascal2019-07-28 22:33:26 -0500
committerAndrea Pascal2019-07-28 22:33:26 -0500
commit0449f58b62ef119f1c35bcdbc855e306d5cdfeb2 (patch)
treec939a0e2281dd897a440917e12cf1b520aa97130
parent98996f33b7c155a7a5810cc35b636c5ea188f61e (diff)
downloadaur-0449f58b62ef119f1c35bcdbc855e306d5cdfeb2.tar.gz
1.12.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--nolibs.patch107
3 files changed, 63 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb28259aaf42..1bc21e6914c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-pylsl
pkgdesc = Python interface to the Lab Streaming Layer
- pkgver = 1.10.5
+ pkgver = 1.12.2
pkgrel = 1
url = https://github.com/labstreaminglayer/liblsl-Python
arch = any
license = MIT
depends = liblsl
conflicts = python-pylsl
- source = https://files.pythonhosted.org/packages/8b/9e/96d8e32a716dfa8071c344742f8acf9942e7bb26cc060a8a71e1385703e8/pylsl-1.10.5.zip
+ source = https://files.pythonhosted.org/packages/5b/1e/71fb9b89c713fcddb63304ee52ae14bc2ba9b20cd7e019e0fe1c92df32af/pylsl-1.12.2.tar.gz
source = nolibs.patch
- sha384sums = 84945e65a75d6a1e95a91648f2b2e70198eb8407ca83160bef7f1984a001983c62a7922919a675c7c6d30ecfb7cb5d7b
- sha384sums = c01b6ef98127a79364f26f15f62d53928fb43b7d1db3da2a3d8ded30e64c754e19f0f02148db74bd96335e6975f2ff2b
+ sha384sums = 86125411f50812bb40aed30af171a9764bf1a5c4af479a5d276806e3fa40919c6548827b850fc900325095c4b7bdb133
+ sha384sums = 5aef54d81924ea8dedfc7f80f73dfd2cd6913f8d2a9085a596c657a816c7bd69bf001e137ca3933651e381efda6bfb80
pkgname = python-pylsl
diff --git a/PKGBUILD b/PKGBUILD
index 411172c273bf..5488b1c331e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-pylsl
pkgname=(python-pylsl python2-pylsl)
_name=${pkgname#python-}
-pkgver=1.10.5
+pkgver=1.12.2
pkgrel=1
pkgdesc='Python interface to the Lab Streaming Layer'
url='https://github.com/labstreaminglayer/liblsl-Python'
@@ -11,10 +11,10 @@ arch=('any')
license=('MIT')
conflicts=($pkgname)
depends=('liblsl')
-source=('https://files.pythonhosted.org/packages/8b/9e/96d8e32a716dfa8071c344742f8acf9942e7bb26cc060a8a71e1385703e8/pylsl-1.10.5.zip'
+source=('https://files.pythonhosted.org/packages/5b/1e/71fb9b89c713fcddb63304ee52ae14bc2ba9b20cd7e019e0fe1c92df32af/pylsl-1.12.2.tar.gz'
'nolibs.patch')
-sha384sums=('84945e65a75d6a1e95a91648f2b2e70198eb8407ca83160bef7f1984a001983c62a7922919a675c7c6d30ecfb7cb5d7b'
- 'c01b6ef98127a79364f26f15f62d53928fb43b7d1db3da2a3d8ded30e64c754e19f0f02148db74bd96335e6975f2ff2b')
+sha384sums=('86125411f50812bb40aed30af171a9764bf1a5c4af479a5d276806e3fa40919c6548827b850fc900325095c4b7bdb133'
+ '5aef54d81924ea8dedfc7f80f73dfd2cd6913f8d2a9085a596c657a816c7bd69bf001e137ca3933651e381efda6bfb80')
prepare(){
cd "$srcdir/$_name-${pkgver}"
diff --git a/nolibs.patch b/nolibs.patch
index e87a80e3f85b..9d659cdaa12d 100644
--- a/nolibs.patch
+++ b/nolibs.patch
@@ -1,63 +1,66 @@
-diff --unified --recursive --text pylsl-1.10.5/MANIFEST.in pylsl-1.10.5.nolibs/MANIFEST.in
---- pylsl-1.10.5/MANIFEST.in 2016-08-26 16:52:50.000000000 -0500
-+++ pylsl-1.10.5.nolibs/MANIFEST.in 2019-07-28 22:15:45.386642468 -0500
+diff --unified --recursive --text pylsl-1.12.2/MANIFEST.in pylsl-1.12.2.nolibs/MANIFEST.in
+--- pylsl-1.12.2/MANIFEST.in 2018-07-26 10:32:58.000000000 -0500
++++ pylsl-1.12.2.nolibs/MANIFEST.in 2019-07-28 22:30:13.715521387 -0500
@@ -1,6 +1,2 @@
- include DESCRIPTION.rst
- include LICENSE
--
--# If using Python 2.6 or less, then have to include package data, even though
--# it's already declared in setup.py
--include pylsl/liblsl*.*
-Only in pylsl-1.10.5/pylsl: liblsl32.dll
-Only in pylsl-1.10.5/pylsl: liblsl32.dylib
-Only in pylsl-1.10.5/pylsl: liblsl32.so
-Only in pylsl-1.10.5/pylsl: liblsl64.dll
-Only in pylsl-1.10.5/pylsl: liblsl64.dylib
-Only in pylsl-1.10.5/pylsl: liblsl64.so
-diff --unified --recursive --text pylsl-1.10.5/pylsl/pylsl.py pylsl-1.10.5.nolibs/pylsl/pylsl.py
---- pylsl-1.10.5/pylsl/pylsl.py 2016-08-26 17:53:56.000000000 -0500
-+++ pylsl-1.10.5.nolibs/pylsl/pylsl.py 2019-07-28 22:16:32.690354072 -0500
-@@ -1141,7 +1141,9 @@
- if not os.path.isfile(libpath):
- libpath = util.find_library(libname)
- if not libpath:
-- raise RuntimeError("library " + libname + " was not found - make sure "
-+ libpath = util.find_library('lsl')
-+ if not libpath:
-+ raise RuntimeError("library " + libname + " was not found - make sure "
- "that it is on the search path (e.g., in the same "
- "folder as pylsl.py).")
- lib = CDLL(libpath)
-diff --unified --recursive --text pylsl-1.10.5/pylsl.egg-info/SOURCES.txt pylsl-1.10.5.nolibs/pylsl.egg-info/SOURCES.txt
---- pylsl-1.10.5/pylsl.egg-info/SOURCES.txt 2016-08-26 18:11:02.000000000 -0500
-+++ pylsl-1.10.5.nolibs/pylsl.egg-info/SOURCES.txt 2019-07-28 22:15:59.433419823 -0500
-@@ -5,12 +5,6 @@
+ include README.md
+ include LICENSE
+-
+-# If using Python 2.6 or less, then have to include package data, even though
+-# it's already declared in setup.py
+-include pylsl/liblsl*.*
+Only in pylsl-1.12.2/pylsl: liblsl32.dll
+Only in pylsl-1.12.2/pylsl: liblsl64.1.12.0.dylib
+Only in pylsl-1.12.2/pylsl: liblsl64.dll
+Only in pylsl-1.12.2/pylsl: liblsl64.dylib
+Only in pylsl-1.12.2/pylsl: liblsl64.so
+Only in pylsl-1.12.2/pylsl: liblsl64.so.1.12.0
+diff --unified --recursive --text pylsl-1.12.2/pylsl/pylsl.py pylsl-1.12.2.nolibs/pylsl/pylsl.py
+--- pylsl-1.12.2/pylsl/pylsl.py 2018-07-27 09:01:45.000000000 -0500
++++ pylsl-1.12.2.nolibs/pylsl/pylsl.py 2019-07-28 22:29:49.148560030 -0500
+@@ -1194,7 +1194,9 @@
+ if not os.path.isfile(libpath):
+ libpath = util.find_library('lsl' + str(bitness))
+ if not libpath:
+- raise RuntimeError("library " + libname + " was not found - make sure "
++ libpath = util.find_library('lsl')
++ if not libpath:
++ raise RuntimeError("library " + libname + " was not found - make sure "
+ "that it is on the search path (e.g., in the same "
+ "folder as pylsl.py).")
+ lib = CDLL(libpath)
+diff --unified --recursive --text pylsl-1.12.2/pylsl.egg-info/SOURCES.txt pylsl-1.12.2.nolibs/pylsl.egg-info/SOURCES.txt
+--- pylsl-1.12.2/pylsl.egg-info/SOURCES.txt 2018-07-27 14:05:20.000000000 -0500
++++ pylsl-1.12.2.nolibs/pylsl.egg-info/SOURCES.txt 2019-07-28 22:30:05.522089561 -0500
+@@ -4,12 +4,6 @@
setup.cfg
setup.py
pylsl/__init__.py
-pylsl/liblsl32.dll
--pylsl/liblsl32.dylib
--pylsl/liblsl32.so
+-pylsl/liblsl64.1.12.0.dylib
-pylsl/liblsl64.dll
-pylsl/liblsl64.dylib
-pylsl/liblsl64.so
+-pylsl/liblsl64.so.1.12.0
pylsl/pylsl.py
pylsl.egg-info/PKG-INFO
pylsl.egg-info/SOURCES.txt
-diff --unified --recursive --text pylsl-1.10.5/setup.py pylsl-1.10.5.nolibs/setup.py
---- pylsl-1.10.5/setup.py 2016-08-26 17:56:24.000000000 -0500
-+++ pylsl-1.10.5.nolibs/setup.py 2019-07-28 22:15:35.586566079 -0500
-@@ -84,13 +84,6 @@
- # $ pip install -e .[dev,test]
- extras_require={},
-
-- # If there are data files included in your packages that need to be
-- # installed, specify them here. If using Python 2.6 or less, then these
-- # have to be included in MANIFEST.in as well.
-- package_data={
-- 'pylsl': ['liblsl32.dll','liblsl64.dll','liblsl32.dylib','liblsl64.dylib','liblsl32.so','liblsl64.so'],
-- },
--
- # Although 'package_data' is the preferred approach, in some case you may
- # need to place data files outside of your packages. See:
- # http://docs.python.org/3.4/distutils/setupscript.html#installing-additional-files # noqa
+diff --unified --recursive --text pylsl-1.12.2/setup.py pylsl-1.12.2.nolibs/setup.py
+--- pylsl-1.12.2/setup.py 2018-07-27 13:57:09.000000000 -0500
++++ pylsl-1.12.2.nolibs/setup.py 2019-07-28 22:30:47.122591750 -0500
+@@ -85,16 +85,6 @@
+ # $ pip install -e .[dev,test]
+ extras_require={},
+
+- # If there are data files included in your packages that need to be
+- # installed, specify them here. If using Python 2.6 or less, then these
+- # have to be included in MANIFEST.in as well.
+- # Here we specify all the shared libs for the different platforms, but
+- # setup will probably only find the one library downloaded by the build
+- # script or placed here manually.
+- package_data={
+- 'pylsl': ['*.dll', '*.dylib', '*.so*'],
+- },
+-
+ # Although 'package_data' is the preferred approach, in some case you may
+ # need to place data files outside of your packages. See:
+ # http://docs.python.org/3.4/distutils/setupscript.html#installing-additional-files # noqa