summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Pascal2019-07-28 22:08:31 -0500
committerAndrea Pascal2019-07-28 22:23:45 -0500
commit34a3444aa0c25e10d9206bccce04918afe72eff4 (patch)
tree466564b8f9cf15567b16412d9e41903656964f39
parent74d568b824985b0987977897fb58cf4eb235d362 (diff)
downloadaur-34a3444aa0c25e10d9206bccce04918afe72eff4.tar.gz
1.10.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--nolibs.patch38
3 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3029089e5f7a..d6c170d74b6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-pylsl
pkgdesc = Python interface to the Lab Streaming Layer
- pkgver = 1.10.3
+ pkgver = 1.10.4
pkgrel = 1
url = https://github.com/labstreaminglayer/liblsl-Python
arch = any
license = MIT
depends = liblsl
conflicts = python-pylsl
- source = https://files.pythonhosted.org/packages/62/42/fe6fba758bfa9301a56e87ec16933a8b6e2860c1aab0719f0aa431a35310/pylsl-1.10.3.zip
+ source = https://files.pythonhosted.org/packages/77/ab/00c451e140d9c333c3e251fdf81560e5b296bf7f9cc411e1b000031db674/pylsl-1.10.4.zip
source = nolibs.patch
- sha384sums = b31bb2560812dc066a63508f751d716679246c03fcda4b3f5e060248091980bd94df17e05e822acf2aab3009923ff24f
- sha384sums = c6030d5f0d97e9a04604cd1e9ba6b163fa1e9a77d821177cb2b17b80e2eb78cf0cbbcc1d718f528e9dbe9f4016d51c53
+ sha384sums = c522ad997f9db2dd02ab6d666eeb9f847a894a2b6cc070220358514ac1a907a2a98e44d2f62bdf61a3239ece6979aafe
+ sha384sums = 1dc1c6df4802b5dde4755c95c0a8350c58b141fc761ddac949d3f13485205a01e161b481e5d23ff3b57a715bcad62deb
pkgname = python-pylsl
diff --git a/PKGBUILD b/PKGBUILD
index 593ce6d92f27..8d54d7018d23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-pylsl
pkgname=(python-pylsl python2-pylsl)
_name=${pkgname#python-}
-pkgver=1.10.3
+pkgver=1.10.4
pkgrel=1
pkgdesc='Python interface to the Lab Streaming Layer'
url='https://github.com/labstreaminglayer/liblsl-Python'
@@ -11,10 +11,10 @@ arch=('any')
license=('MIT')
conflicts=($pkgname)
depends=('liblsl')
-source=('https://files.pythonhosted.org/packages/62/42/fe6fba758bfa9301a56e87ec16933a8b6e2860c1aab0719f0aa431a35310/pylsl-1.10.3.zip'
+source=('https://files.pythonhosted.org/packages/77/ab/00c451e140d9c333c3e251fdf81560e5b296bf7f9cc411e1b000031db674/pylsl-1.10.4.zip'
'nolibs.patch')
-sha384sums=('b31bb2560812dc066a63508f751d716679246c03fcda4b3f5e060248091980bd94df17e05e822acf2aab3009923ff24f'
- 'c6030d5f0d97e9a04604cd1e9ba6b163fa1e9a77d821177cb2b17b80e2eb78cf0cbbcc1d718f528e9dbe9f4016d51c53')
+sha384sums=('c522ad997f9db2dd02ab6d666eeb9f847a894a2b6cc070220358514ac1a907a2a98e44d2f62bdf61a3239ece6979aafe'
+ '1dc1c6df4802b5dde4755c95c0a8350c58b141fc761ddac949d3f13485205a01e161b481e5d23ff3b57a715bcad62deb')
prepare(){
cd "$srcdir/$_name-${pkgver}"
diff --git a/nolibs.patch b/nolibs.patch
index 5bd805abcb8e..5e22845c4e4b 100644
--- a/nolibs.patch
+++ b/nolibs.patch
@@ -1,6 +1,6 @@
-diff --unified --recursive --text pylsl-1.10.3/MANIFEST.in pylsl-1.10.3.nolibs/MANIFEST.in
---- pylsl-1.10.3/MANIFEST.in 2015-04-24 20:51:56.000000000 -0500
-+++ pylsl-1.10.3.nolibs/MANIFEST.in 2019-07-28 21:47:09.512022467 -0500
+diff --unified --recursive --text pylsl-1.10.4/MANIFEST.in pylsl-1.10.4.nolibs/MANIFEST.in
+--- pylsl-1.10.4/MANIFEST.in 2015-04-24 20:51:56.000000000 -0500
++++ pylsl-1.10.4.nolibs/MANIFEST.in 2019-07-28 22:05:54.866765165 -0500
@@ -1,6 +1,2 @@
include DESCRIPTION.rst
include LICENSE
@@ -8,16 +8,16 @@ diff --unified --recursive --text pylsl-1.10.3/MANIFEST.in pylsl-1.10.3.nolibs/M
-# If using Python 2.6 or less, then have to include package data, even though
-# it's already declared in setup.py
-include pylsl/liblsl*.*
-Only in pylsl-1.10.3/pylsl: liblsl32.dll
-Only in pylsl-1.10.3/pylsl: liblsl32.dylib
-Only in pylsl-1.10.3/pylsl: liblsl32.so
-Only in pylsl-1.10.3/pylsl: liblsl64.dll
-Only in pylsl-1.10.3/pylsl: liblsl64.dylib
-Only in pylsl-1.10.3/pylsl: liblsl64.so
-diff --unified --recursive --text pylsl-1.10.3/pylsl/pylsl.py pylsl-1.10.3.nolibs/pylsl/pylsl.py
---- pylsl-1.10.3/pylsl/pylsl.py 2015-04-24 18:16:52.000000000 -0500
-+++ pylsl-1.10.3.nolibs/pylsl/pylsl.py 2019-07-28 21:46:44.068319850 -0500
-@@ -1137,7 +1137,9 @@
+Only in pylsl-1.10.4/pylsl: liblsl32.dll
+Only in pylsl-1.10.4/pylsl: liblsl32.dylib
+Only in pylsl-1.10.4/pylsl: liblsl32.so
+Only in pylsl-1.10.4/pylsl: liblsl64.dll
+Only in pylsl-1.10.4/pylsl: liblsl64.dylib
+Only in pylsl-1.10.4/pylsl: liblsl64.so
+diff --unified --recursive --text pylsl-1.10.4/pylsl/pylsl.py pylsl-1.10.4.nolibs/pylsl/pylsl.py
+--- pylsl-1.10.4/pylsl/pylsl.py 2015-05-03 20:04:18.000000000 -0500
++++ pylsl-1.10.4.nolibs/pylsl/pylsl.py 2019-07-28 22:05:20.222839962 -0500
+@@ -1141,7 +1141,9 @@
if not os.path.isfile(libpath):
libpath = util.find_library(libname)
if not libpath:
@@ -28,9 +28,9 @@ diff --unified --recursive --text pylsl-1.10.3/pylsl/pylsl.py pylsl-1.10.3.nolib
"that it is on the search path (e.g., in the same "
"folder as pylsl.py).")
lib = CDLL(libpath)
-diff --unified --recursive --text pylsl-1.10.3/pylsl.egg-info/SOURCES.txt pylsl-1.10.3.nolibs/pylsl.egg-info/SOURCES.txt
---- pylsl-1.10.3/pylsl.egg-info/SOURCES.txt 2015-04-24 20:55:00.000000000 -0500
-+++ pylsl-1.10.3.nolibs/pylsl.egg-info/SOURCES.txt 2019-07-28 21:46:57.168509677 -0500
+diff --unified --recursive --text pylsl-1.10.4/pylsl.egg-info/SOURCES.txt pylsl-1.10.4.nolibs/pylsl.egg-info/SOURCES.txt
+--- pylsl-1.10.4/pylsl.egg-info/SOURCES.txt 2015-05-03 20:06:40.000000000 -0500
++++ pylsl-1.10.4.nolibs/pylsl.egg-info/SOURCES.txt 2019-07-28 22:05:43.563238559 -0500
@@ -5,12 +5,6 @@
setup.cfg
setup.py
@@ -44,9 +44,9 @@ diff --unified --recursive --text pylsl-1.10.3/pylsl.egg-info/SOURCES.txt pylsl-
pylsl/pylsl.py
pylsl.egg-info/PKG-INFO
pylsl.egg-info/SOURCES.txt
-diff --unified --recursive --text pylsl-1.10.3/setup.py pylsl-1.10.3.nolibs/setup.py
---- pylsl-1.10.3/setup.py 2015-04-24 20:44:06.000000000 -0500
-+++ pylsl-1.10.3.nolibs/setup.py 2019-07-28 21:47:24.585575715 -0500
+diff --unified --recursive --text pylsl-1.10.4/setup.py pylsl-1.10.4.nolibs/setup.py
+--- pylsl-1.10.4/setup.py 2015-05-03 20:04:30.000000000 -0500
++++ pylsl-1.10.4.nolibs/setup.py 2019-07-28 22:06:09.753583484 -0500
@@ -84,13 +84,6 @@
# $ pip install -e .[dev,test]
extras_require={},