summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Pascal2019-07-28 21:59:21 -0500
committerAndrea Pascal2019-07-28 22:23:27 -0500
commit74d568b824985b0987977897fb58cf4eb235d362 (patch)
tree7558916fc99dc052648e839bdd68089f231ba4be
downloadaur-74d568b824985b0987977897fb58cf4eb235d362.tar.gz
1.10.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
-rw-r--r--nolibs.patch63
3 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3029089e5f7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pylsl
+ pkgdesc = Python interface to the Lab Streaming Layer
+ pkgver = 1.10.3
+ pkgrel = 1
+ url = https://github.com/labstreaminglayer/liblsl-Python
+ arch = any
+ license = MIT
+ depends = liblsl
+ conflicts = python-pylsl
+ source = https://files.pythonhosted.org/packages/62/42/fe6fba758bfa9301a56e87ec16933a8b6e2860c1aab0719f0aa431a35310/pylsl-1.10.3.zip
+ source = nolibs.patch
+ sha384sums = b31bb2560812dc066a63508f751d716679246c03fcda4b3f5e060248091980bd94df17e05e822acf2aab3009923ff24f
+ sha384sums = c6030d5f0d97e9a04604cd1e9ba6b163fa1e9a77d821177cb2b17b80e2eb78cf0cbbcc1d718f528e9dbe9f4016d51c53
+
+pkgname = python-pylsl
+
+pkgname = python2-pylsl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..593ce6d92f27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Andrea Pascal <andrea@anodium.net>
+
+pkgbase=python-pylsl
+pkgname=(python-pylsl python2-pylsl)
+_name=${pkgname#python-}
+pkgver=1.10.3
+pkgrel=1
+pkgdesc='Python interface to the Lab Streaming Layer'
+url='https://github.com/labstreaminglayer/liblsl-Python'
+arch=('any')
+license=('MIT')
+conflicts=($pkgname)
+depends=('liblsl')
+source=('https://files.pythonhosted.org/packages/62/42/fe6fba758bfa9301a56e87ec16933a8b6e2860c1aab0719f0aa431a35310/pylsl-1.10.3.zip'
+ 'nolibs.patch')
+sha384sums=('b31bb2560812dc066a63508f751d716679246c03fcda4b3f5e060248091980bd94df17e05e822acf2aab3009923ff24f'
+ 'c6030d5f0d97e9a04604cd1e9ba6b163fa1e9a77d821177cb2b17b80e2eb78cf0cbbcc1d718f528e9dbe9f4016d51c53')
+
+prepare(){
+ cd "$srcdir/$_name-${pkgver}"
+ patch --strip=1 --input=../nolibs.patch
+}
+
+build(){
+ cd "$srcdir/$_name-${pkgver}"
+ python setup.py build
+ python2 setup.py build
+}
+
+check(){
+ cd "$srcdir/$_name-${pkgver}"
+ python setup.py check -m -s
+ python2 setup.py check -m -s
+}
+
+package_python-pylsl() {
+ makedepends=('python-setuptools')
+ cd "$srcdir/$_name-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-pylsl() {
+ makedepends=('python2-setuptools')
+ cd "$srcdir/$_name-${pkgver}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/nolibs.patch b/nolibs.patch
new file mode 100644
index 000000000000..5bd805abcb8e
--- /dev/null
+++ b/nolibs.patch
@@ -0,0 +1,63 @@
+diff --unified --recursive --text pylsl-1.10.3/MANIFEST.in pylsl-1.10.3.nolibs/MANIFEST.in
+--- pylsl-1.10.3/MANIFEST.in 2015-04-24 20:51:56.000000000 -0500
++++ pylsl-1.10.3.nolibs/MANIFEST.in 2019-07-28 21:47:09.512022467 -0500
+@@ -1,6 +1,2 @@
+ include DESCRIPTION.rst
+ include LICENSE
+-
+-# If using Python 2.6 or less, then have to include package data, even though
+-# it's already declared in setup.py
+-include pylsl/liblsl*.*
+Only in pylsl-1.10.3/pylsl: liblsl32.dll
+Only in pylsl-1.10.3/pylsl: liblsl32.dylib
+Only in pylsl-1.10.3/pylsl: liblsl32.so
+Only in pylsl-1.10.3/pylsl: liblsl64.dll
+Only in pylsl-1.10.3/pylsl: liblsl64.dylib
+Only in pylsl-1.10.3/pylsl: liblsl64.so
+diff --unified --recursive --text pylsl-1.10.3/pylsl/pylsl.py pylsl-1.10.3.nolibs/pylsl/pylsl.py
+--- pylsl-1.10.3/pylsl/pylsl.py 2015-04-24 18:16:52.000000000 -0500
++++ pylsl-1.10.3.nolibs/pylsl/pylsl.py 2019-07-28 21:46:44.068319850 -0500
+@@ -1137,7 +1137,9 @@
+ if not os.path.isfile(libpath):
+ libpath = util.find_library(libname)
+ if not libpath:
+- raise RuntimeError("library " + libname + " was not found - make sure "
++ libpath = util.find_library('lsl')
++ if not libpath:
++ raise RuntimeError("library " + libname + " was not found - make sure "
+ "that it is on the search path (e.g., in the same "
+ "folder as pylsl.py).")
+ lib = CDLL(libpath)
+diff --unified --recursive --text pylsl-1.10.3/pylsl.egg-info/SOURCES.txt pylsl-1.10.3.nolibs/pylsl.egg-info/SOURCES.txt
+--- pylsl-1.10.3/pylsl.egg-info/SOURCES.txt 2015-04-24 20:55:00.000000000 -0500
++++ pylsl-1.10.3.nolibs/pylsl.egg-info/SOURCES.txt 2019-07-28 21:46:57.168509677 -0500
+@@ -5,12 +5,6 @@
+ setup.cfg
+ setup.py
+ pylsl/__init__.py
+-pylsl/liblsl32.dll
+-pylsl/liblsl32.dylib
+-pylsl/liblsl32.so
+-pylsl/liblsl64.dll
+-pylsl/liblsl64.dylib
+-pylsl/liblsl64.so
+ pylsl/pylsl.py
+ pylsl.egg-info/PKG-INFO
+ pylsl.egg-info/SOURCES.txt
+diff --unified --recursive --text pylsl-1.10.3/setup.py pylsl-1.10.3.nolibs/setup.py
+--- pylsl-1.10.3/setup.py 2015-04-24 20:44:06.000000000 -0500
++++ pylsl-1.10.3.nolibs/setup.py 2019-07-28 21:47:24.585575715 -0500
+@@ -84,13 +84,6 @@
+ # $ pip install -e .[dev,test]
+ extras_require={},
+
+- # If there are data files included in your packages that need to be
+- # installed, specify them here. If using Python 2.6 or less, then these
+- # have to be included in MANIFEST.in as well.
+- package_data={
+- 'pylsl': ['liblsl32.dll','liblsl64.dll','liblsl32.dylib','liblsl64.dylib','liblsl32.so','liblsl64.so'],
+- },
+-
+ # Although 'package_data' is the preferred approach, in some case you may
+ # need to place data files outside of your packages. See:
+ # http://docs.python.org/3.4/distutils/setupscript.html#installing-additional-files # noqa