summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2022-11-20 17:22:22 +1100
committerRhinoceros2022-11-20 17:22:22 +1100
commit03bb4e7a14ff93e742695f2ade3e61cf03393d70 (patch)
treeb78f5fce6f4b24aba9a571d66c30ab57669cd5cd
parentf398ba5db9325f2c05b601c0b678c043a6f35b98 (diff)
downloadaur-03bb4e7a14ff93e742695f2ade3e61cf03393d70.tar.gz
* remove check: needs the package itself to be installed to run?!
* minor style changes
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48aa5f1fa956..3d46d5e7f703 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,23 +20,24 @@ sha256sums=('baefed4c84d147a507a606206478ff0894e04fa41aa3742381159cde44836fc3'
noextract=(ux.stackexchange.com.$_testing_data_version.7z)
prepare() {
- ln -s ../../../ux.stackexchange.com.$_testing_data_version.7z $_pkgname-$pkgver/tests/data/ux.stackexchange.com.7z
+ ln -s ../../../ux.stackexchange.com.$_testing_data_version.7z $_pkgname-$pkgver/tests/data/ux.stackexchange.com.7z
}
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py build
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
}
-check() {
- cd "$srcdir/$_pkgname-$pkgver"
- PYTHONPATH="$PWD:$PWD/build/lib.linux-$CARCH-3.10" python tests/__init__.py
-}
+# This package itself needs to be installed for the check to work, so I'm just going to disable it
+# check() {
+# cd "$srcdir/$_pkgname-$pkgver"
+# PYTHONPATH="$PWD:$PWD/build/lib.linux-$CARCH-3.10" python tests/__init__.py
+# }
-package_python-pylzma() {
- depends=('python')
- conflicts=('pylzma')
+package() {
+ depends=('python')
+ conflicts=('pylzma')
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
}