summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2020-12-03 10:17:08 +1100
committerRhinoceros2020-12-03 10:17:08 +1100
commit9d33b88f6dd581382743c7113743dea862587e73 (patch)
tree989dccf84079a325b67a739bca92498bf73672b3
parentc0cbf0bc0a82ad0669f3e12395c4e68c323c90f3 (diff)
downloadaur-9d33b88f6dd581382743c7113743dea862587e73.tar.gz
Give downloaded testing data a unique filename
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d1b03f0426e..8ec1c9684bc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,9 +8,9 @@ pkgbase = python-pylzma
license = LGPL2.1
makedepends = python-setuptools
makedepends = python2-setuptools
- noextract = ux.stackexchange.com.7z
+ noextract = ux.stackexchange.com.201203.7z
source = pylzma-0.5.0.tar.gz::https://github.com/fancycode/pylzma/archive/v0.5.0.tar.gz
- source = https://archive.org/download/stackexchange/ux.stackexchange.com.7z
+ source = ux.stackexchange.com.201203.7z::https://archive.org/download/stackexchange/ux.stackexchange.com.7z
sha256sums = baefed4c84d147a507a606206478ff0894e04fa41aa3742381159cde44836fc3
sha256sums = 9296524c4514568d1047d64dea5e92a58d3efcba0b61b4533b230f1efb16d0b6
diff --git a/PKGBUILD b/PKGBUILD
index 6555a98ba7b0..38b4cb5647ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,12 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Penguin <TGates81.at.gmail.dot.com>
_pkgname=pylzma
pkgbase=python-$_pkgname
pkgname=(python-$_pkgname python2-$_pkgname)
pkgver=0.5.0
+_testing_data_version=201203
pkgrel=3
pkgdesc="Platform independent python bindings for the LZMA compression library"
url="https://www.joachim-bauch.de/projects/pylzma/"
@@ -13,16 +15,16 @@ arch=(i686 x86_64)
makedepends=('python-setuptools' 'python2-setuptools')
source=($_pkgname-$pkgver.tar.gz::https://github.com/fancycode/pylzma/archive/v$pkgver.tar.gz
# testing data
- https://archive.org/download/stackexchange/ux.stackexchange.com.7z)
+ ux.stackexchange.com.$_testing_data_version.7z::https://archive.org/download/stackexchange/ux.stackexchange.com.7z)
sha256sums=('baefed4c84d147a507a606206478ff0894e04fa41aa3742381159cde44836fc3'
'9296524c4514568d1047d64dea5e92a58d3efcba0b61b4533b230f1efb16d0b6')
-noextract=(ux.stackexchange.com.7z)
+noextract=(ux.stackexchange.com.$_testing_data_version.7z)
prepare() {
cp -r $_pkgname-$pkgver{,-py2}
- ln -s ../../../ux.stackexchange.com.7z $_pkgname-$pkgver/tests/data/
- ln -s ../../../ux.stackexchange.com.7z $_pkgname-$pkgver-py2/tests/data/
+ ln -s ../../../ux.stackexchange.com.$_testing_data_version.7z $_pkgname-$pkgver/tests/data/ux.stackexchange.com.7z
+ ln -s ../../../ux.stackexchange.com.$_testing_data_version.7z $_pkgname-$pkgver-py2/tests/data/ux.stackexchange.com.7z
sed -i 's#/usr/bin/python -u#/usr/bin/python2 -u#' $_pkgname-$pkgver-py2/py7zlib.py
}