summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-10-13 15:10:47 -0500
committerCarlos Aznarán2023-10-13 15:10:47 -0500
commit1a7f20e81a91984c337e61aa5be5c0c187243a2a (patch)
tree60940132e216f0031d6ee7e32c3ec84f7232e797
parent9c4078667628985ad3589d2fe8dd8baaeff114cf (diff)
downloadaur-1a7f20e81a91984c337e61aa5be5c0c187243a2a.tar.gz
Bump version to 2.2.0
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD52
3 files changed, 51 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45a379545594..375e069d6084 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,25 @@
pkgbase = python-pymanopt
- pkgdesc = Python toolbox for optimization on manifolds with support for automatic differentiation
- pkgver = 2.1.1
+ pkgdesc = Toolbox for optimization on Riemannian manifolds with support for automatic differentiation
+ pkgver = 2.2.0
pkgrel = 1
url = https://pymanopt.github.io
arch = x86_64
- license = MIT
- makedepends = python
- makedepends = python-setuptools
- depends = python-numpy
+ license = custom:BSD-3-clause
+ checkdepends = python-pytest
+ checkdepends = python-autograd
+ checkdepends = python-tensorflow
+ checkdepends = python-pytorch
+ checkdepends = python-jax
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools-scm
+ makedepends = python-wheel
depends = python-scipy
- optdepends = python-tensorflow
- optdepends = python-autograd
- source = python-pymanopt-2.1.1.tar.gz::https://github.com/pymanopt/pymanopt/archive/2.1.1.tar.gz
- md5sums = 9981b30b21ef1da6265dbcb193c2e50c
+ optdepends = python-autograd: for support
+ optdepends = python-jax: for support
+ optdepends = python-tensorflow: for support
+ optdepends = python-pytorch: for support
+ source = python-pymanopt-2.2.0.tar.gz::https://github.com/pymanopt/pymanopt/archive/2.2.0.tar.gz
+ sha512sums = 89ea7055de53bf7cf241c5f5e21f5ac449b3e82fa7c4ecbe572f769c5d75481ff0e8aa0cfbcb4d5666c79ae3dc75eb24bc3426d492998860a60cefa254cc184f
pkgname = python-pymanopt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index 72f06887e06c..9f3e7725cc2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,39 @@
-# Maintainer: Leo Mao <leomaoyw at gmail dot com>
-pkgname=python-pymanopt
-_pkgname=pymanopt
-pkgver=2.1.1
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Leo Mao <leomaoyw at gmail dot com>
+_base=pymanopt
+pkgname=python-${_base}
+pkgdesc="Toolbox for optimization on Riemannian manifolds with support for automatic differentiation"
+pkgver=2.2.0
pkgrel=1
-pkgdesc="Python toolbox for optimization on manifolds with support for automatic differentiation"
-_pypiname="pymanopt"
-#_github="pymanopt/pymanopt"
-url="https://pymanopt.github.io"
-arch=('x86_64')
-license=('MIT')
-depends=('python-numpy' 'python-scipy')
-optdepends=('python-tensorflow' 'python-autograd')
-makedepends=('python' 'python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/pymanopt/pymanopt/archive/$pkgver.tar.gz")
-md5sums=('9981b30b21ef1da6265dbcb193c2e50c')
+arch=(x86_64)
+url="https://${_base}.github.io"
+license=('custom:BSD-3-clause')
+depends=(python-scipy)
+makedepends=(python-build python-installer python-setuptools-scm python-wheel)
+checkdepends=(python-pytest python-autograd python-tensorflow python-pytorch python-jax)
+optdepends=('python-autograd: for support'
+ 'python-jax: for support'
+ 'python-tensorflow: for support'
+ 'python-pytorch: for support')
+source=($pkgname-$pkgver.tar.gz::https://github.com/${_base}/${_base}/archive/${pkgver}.tar.gz)
+sha512sums=('89ea7055de53bf7cf241c5f5e21f5ac449b3e82fa7c4ecbe572f769c5d75481ff0e8aa0cfbcb4d5666c79ae3dc75eb24bc3426d492998860a60cefa254cc184f')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py build
+ cd ${_base}-${pkgver}
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest -k 'not multiexpm_conjugate_symmetric and not SpecialOrthogonalGroup and not UnitaryGroup and not TestSingleStiefelManifold and not TestMultiStiefelManifold' \
+ --ignore=tests/manifolds/test_positive_definite.py
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}