summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-07-11 18:22:20 +0200
committerMarcell Meszaros2022-07-11 18:22:20 +0200
commitf4207fdd2fc69f3d715d6510110d8645029f5dde (patch)
tree3804ac65e9e38ed313369267adb9a9c7be4316a5
parent3fff73fa4bd21057a7696e4f66e26585218ed54d (diff)
downloadaur-f4207fdd2fc69f3d715d6510110d8645029f5dde.tar.gz
0.2.5-2: remove unneeded python-lepl dependency
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD35
3 files changed, 39 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48fada7a0353..0561d9b89e67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-pymantic
pkgdesc = Semantic Web and RDF library for Python
pkgver = 0.2.5
- pkgrel = 1
- url = https://github.com/norcalrdf/pymantic/
+ pkgrel = 2
+ url = https://pypi.org/project/pymantic/0.2.5
arch = any
license = BSD
makedepends = python-setuptools
@@ -13,17 +13,9 @@ pkgbase = python-pymantic
depends = python-rdflib
depends = python-lark-parser
depends = python-pyld
- depends = python-lepl
source = https://files.pythonhosted.org/packages/source/p/pymantic/pymantic-0.2.5.tar.gz
+ source = pymantic-0.2.5-LICENSE::https://github.com/norcalrdf/pymantic/raw/0.2.5/LICENSE
sha256sums = 119361a60d811aea6f57faf05f9aebc787e37244e3c8e9c922e9621b2a425dcf
+ sha256sums = c5a804cb694b36e4604f1edaf496ad7aaa93690d27666a6a7887354ec3a1a884
pkgname = python-pymantic
- depends = python
- depends = python-requests
- depends = python-lxml
- depends = python-pytz
- depends = python-rdflib
- depends = python-lark-parser
- depends = python-pyld
- depends = python-lepl
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6696e5c62eee
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+
+*/
+*.orig
+*.bak
+*.backup
diff --git a/PKGBUILD b/PKGBUILD
index e6176651202e..ac82bf2d722c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Initial commit: Alexey Andreyev aa13q at ya.ru
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Alexey Andreyev aa13q at ya.ru
-pkgbase='python-pymantic'
-pkgname=('python-pymantic')
-_module='pymantic'
-pkgver='0.2.5'
-pkgrel=1
+pkgname='python-pymantic'
+_module="${pkgname#python-}"
+pkgver=0.2.5
+pkgrel=2
pkgdesc="Semantic Web and RDF library for Python"
-url="https://github.com/norcalrdf/pymantic/"
-depends=('python' 'python-requests' 'python-lxml' 'python-pytz' 'python-rdflib' 'python-lark-parser' 'python-pyld' 'python-lepl')
-makedepends=('python-setuptools')
-license=('BSD')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('119361a60d811aea6f57faf05f9aebc787e37244e3c8e9c922e9621b2a425dcf')
+url="https://pypi.org/project/${_module}/${pkgver}"
+license=('BSD')
+depends=('python' 'python-requests' 'python-lxml' 'python-pytz' 'python-rdflib' 'python-lark-parser' 'python-pyld')
+makedepends=('python-setuptools')
+_sourcename="${_module}-${pkgver}"
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_sourcename}.tar.gz"
+ "${_sourcename}-LICENSE::https://github.com/norcalrdf/${_module}/raw/${pkgver}/LICENSE")
+sha256sums=('119361a60d811aea6f57faf05f9aebc787e37244e3c8e9c922e9621b2a425dcf'
+ 'c5a804cb694b36e4604f1edaf496ad7aaa93690d27666a6a7887354ec3a1a884')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ cd "${_sourcename}"
+ python setup.py build --executable='/usr/bin/env python'
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_sourcename}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install --verbose -Dm 644 "../${_sourcename}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}