summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:00:08 +0200
committerAlexander F Rødseth2015-06-10 15:00:08 +0200
commita01ac343c63cf36b30a6a60be418de2dc60d2924 (patch)
tree615179515759bbe2c4d04daf7a39d620bd375aee
downloadaur-a01ac343c63cf36b30a6a60be418de2dc60d2924.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61a81e09e865
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pymatic-git
+ pkgdesc = Python library for automating GUI applications (alpha version)
+ pkgver = 74e32d9
+ pkgrel = 1
+ url = http://github.com/xyproto/pymatic
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = python
+ depends = xautomation
+ depends = xorg-server-xvfb
+ depends = zenity
+ depends = scrot
+ depends = gocr
+ source = pymatic::git://github.com/xyproto/pymatic.git
+ md5sums = SKIP
+
+pkgname = python-pymatic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..884670cecd67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=python-pymatic-git
+pkgver=74e32d9
+pkgrel=1
+pkgdesc='Python library for automating GUI applications (alpha version)'
+arch=('x86_64' 'i686')
+url='http://github.com/xyproto/pymatic'
+license=('GPL2')
+depends=('python' 'xautomation' 'xorg-server-xvfb' 'zenity' 'scrot' 'gocr')
+source=('pymatic::git://github.com/xyproto/pymatic.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd pymatic
+
+ git describe --always | sed 's|-|.|g'
+}
+
+check() {
+ cd pymatic
+
+ python setup.py test
+}
+
+check() {
+ cd pymatic
+
+ python setup.py build
+}
+
+package() {
+ cd pymatic
+
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/LICENSE"
+ install -Dm644 examples/main.py "$pkgdir/usr/share/doc/pymatic/main.py"
+}
+
+# vim:set ts=2 sw=2 et: