summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Calsaverini2016-06-30 21:21:41 +0000
committerRafael Calsaverini2016-06-30 21:21:41 +0000
commitd7f4cf1ab62ebd21c2966a52f3c8911dbc6a1104 (patch)
tree1f85addfb72795fd1b94496879e93918fac42d6f
downloadaur-d7f4cf1ab62ebd21c2966a52f3c8911dbc6a1104.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD23
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b03041e22e16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-pymc3-git
+ pkgdesc = Probabilistic Programming in Python. Uses Theano as a backend, supports NUTS and ADVI.
+ pkgver = v3.0beta.r653.g935779a
+ pkgrel = 1
+ url = http://pymc-devs.github.io/pymc3/
+ arch = any
+ license = APACHE
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-joblib
+ depends = python-scipy
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-theano
+ depends = python-pandas
+ conflicts = python-pymc3
+ options = !emptydirs
+ source = git+https://github.com/pymc-devs/pymc3.git
+ md5sums = SKIP
+
+pkgname = python-pymc3-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c167824eb8eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+key_bucket_filename="key.p")me=python-pymc3-git
+pkgver=v3.0beta.r653.g935779a
+pkgrel=1
+pkgdesc="Probabilistic Programming in Python. Uses Theano as a backend, supports NUTS and ADVI."
+arch=('any')
+url="http://pymc-devs.github.io/pymc3/"
+license=('APACHE')
+depends=('python-joblib' 'python-scipy' 'python-numpy' 'python-matplotlib' 'python-theano' 'python-pandas')
+conflicts=('python-pymc3')
+makedepends=('git' 'python-setuptools')
+options=(!emptydirs)
+source=("git+https://github.com/pymc-devs/pymc3.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pymc3"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/pymc3"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}