summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2018-10-21 11:40:01 +0100
committergetzze2018-10-21 11:40:01 +0100
commitd3d531ad4841effbec41e4170cddc31b11d93ede (patch)
treed2afbfc1937a2bf2200299179385862e6222be57
parent1522f8572a7c9cdb279424e9d17832cc127a7b96 (diff)
downloadaur-d3d531ad4841effbec41e4170cddc31b11d93ede.tar.gz
bump 1.0.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58068f086cc6..efb018c3d035 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-pymemoize
pkgdesc = Simple Python cache and memoizing module
- pkgver = 1.0.2
+ pkgver = 1.0.3
pkgrel = 1
- url = https://github.com/EliotBerriot/PyMemoize
+ url = https://github.com/mikeboers/PyMemoize
arch = any
license = BSD
makedepends = git
makedepends = python-setuptools
makedepends = python2-setuptools
options = !emptydirs
- source = git+https://github.com/EliotBerriot/PyMemoize#branch=django
- sha256sums = SKIP
+ source = https://github.com/mikeboers/PyMemoize/archive/v1.0.3.tar.gz
+ sha256sums = 21946d8cf60b80f71438256d8376b76375002ecfbb95d792588f22bea79cd0ee
pkgname = python-pymemoize
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 2ea1583466d1..c559eaf5771a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,23 @@
# Maintainer: getzze <getzze at gmail dot com>
pkgname=('python-pymemoize' 'python2-pymemoize')
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="Simple Python cache and memoizing module"
arch=(any)
-url="https://github.com/EliotBerriot/PyMemoize"
+url="https://github.com/mikeboers/PyMemoize"
license=('BSD')
options=(!emptydirs)
-source=("git+https://github.com/EliotBerriot/PyMemoize#branch=django")
-sha256sums=('SKIP')
+source=("https://github.com/mikeboers/PyMemoize/archive/v${pkgver}.tar.gz")
+sha256sums=('21946d8cf60b80f71438256d8376b76375002ecfbb95d792588f22bea79cd0ee')
makedepends=('git' 'python-setuptools' 'python2-setuptools')
-pkgver() {
- cd "PyMemoize"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
package_python-pymemoize() {
depends=('python')
optdepends=('python-django' 'python-redis')
cd "$srcdir/PyMemoize"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --root="$pkgdir/" --optimize=1
}
@@ -29,6 +25,6 @@ package_python2-pymemoize() {
depends=('python2')
optdepends=('python2-django' 'python2-redis')
cd "$srcdir/PyMemoize"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python2 setup.py install --root="$pkgdir/" --optimize=1
}