summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHezekiah Michael2019-10-25 13:46:35 -0400
committerHezekiah Michael2019-10-25 13:46:35 -0400
commitef5638416abf20c4120fcd05d323cf9915870b77 (patch)
tree44ae4e896bd1bf141059f22359adcef717a0986c
downloadaur-ef5638416abf20c4120fcd05d323cf9915870b77.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8e3f113a4bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-pymkv
+ pkgdesc = A Python wrapper for mkvmerge that provides support for muxing, splitting, linking, chapters, tags, and attachments.
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/sheldonkwoodward/pymkv
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = mkvtoolnix-cli
+ depends = python-iso639
+ depends = python-bitmath
+ source = https://files.pythonhosted.org/packages/source/p/pymkv/pymkv-1.0.5.tar.gz
+ sha256sums = 12942c3af5cf8c5b2fede3318e84b7f339f1e12a3ea316a632ad16223c592e42
+
+pkgname = python-pymkv
+ depends = python
+ depends = mkvtoolnix-cli
+ depends = python-iso639
+ depends = python-bitmath
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c230193ac7b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b4996930874
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Hezekiah Michael <spiritomb at protonmail dot com>
+
+pkgbase='python-pymkv'
+pkgname=('python-pymkv')
+_module='pymkv'
+pkgver='1.0.5'
+pkgrel=1
+pkgdesc="A Python wrapper for mkvmerge that provides support for muxing, splitting, linking, chapters, tags, and attachments."
+url="https://github.com/sheldonkwoodward/pymkv"
+depends=('python' 'mkvtoolnix-cli' 'python-iso639' 'python-bitmath')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('12942c3af5cf8c5b2fede3318e84b7f339f1e12a3ea316a632ad16223c592e42')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ install -D -m644 LICENSE.txt -t "${pkgdir}/usr/share/licences/${pkgname}/LICENSE.txt"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}