summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoen2016-06-24 07:31:17 +0000
committerLoen2016-06-24 07:31:17 +0000
commit1132ab330f84aa860c95e16f2813ee856c4030f9 (patch)
tree63e90b790a829593e256e2db9c13a7059d75b3a4
parentae51b156c90a793fa3ea14c377a71c6c28225471 (diff)
downloadaur-1132ab330f84aa860c95e16f2813ee856c4030f9.tar.gz
First Loen commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eb7036c0716..b1e2ba7a06b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-pympler
pkgdesc = Measure, monitor and analyze the memory behavior of Python objects
- pkgver = 0.4.2
+ pkgver = 0.4.3
pkgrel = 1
- url = http://pypi.python.org/pypi/pympler/
+ url = http://pythonhosted.org/Pympler/
arch = any
- license = Apache
+ license = Apache2
+ makedepends = python2-pip
+ makedepends = python-pip
depends = python
- source = http://pypi.python.org/packages/source/P/Pympler/Pympler-0.4.2.tar.gz
- md5sums = 6bdfd913ad4c94036e8a2b358e49abd7
+ source = https://pypi.python.org/packages/7c/4d/7da5db3fa5939f661b92d46b3918ae57449a8522507e6562c586a7491d0e/Pympler-0.4.3.tar.gz
+ md5sums = bbb4239126e9c99e2effc83b02bf8755
pkgname = python-pympler
diff --git a/PKGBUILD b/PKGBUILD
index 1b3fd14ce2bd..dd1d9557034d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Contributor: Antony Lee <anntzer dot lee at gmail dot com>
-pkgname=python-pympler
-pkgver=0.4.2
+pkgname='python-pympler'
+pkgver='0.4.3'
pkgrel=1
pkgdesc='Measure, monitor and analyze the memory behavior of Python objects'
arch=('any')
-url='http://pypi.python.org/pypi/pympler/'
-license=('Apache')
+url='http://pythonhosted.org/Pympler/'
+license=('Apache2')
depends=('python')
-source=("http://pypi.python.org/packages/source/P/Pympler/Pympler-$pkgver.tar.gz")
-md5sums=('6bdfd913ad4c94036e8a2b358e49abd7')
-
-build() {
- cd "$srcdir/Pympler-$pkgver"
- python setup.py build
-}
+makedepends=('python2-pip' 'python-pip')
+source=('https://pypi.python.org/packages/7c/4d/7da5db3fa5939f661b92d46b3918ae57449a8522507e6562c586a7491d0e/Pympler-0.4.3.tar.gz')
+md5sums=('bbb4239126e9c99e2effc83b02bf8755')
package() {
- cd "$srcdir/Pympler-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/Pympler-${pkgver}"
+ echo :: Installing for python2.7 ...
+ pip2 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
+ echo :: Installing for python3.5 ...
+ pip install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}