summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Lee2015-06-10 17:46:51 -0700
committerAntony Lee2015-06-10 17:46:51 -0700
commit6b3ee980eb757424e883f62cea55431e6a28ecd9 (patch)
tree82654830964aed3f58a88bf9b31f0a9824bf1f61
downloadaur-6b3ee980eb757424e883f62cea55431e6a28ecd9.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37a475c8ebb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-pympler
+ pkgdesc = Measure, monitor and analyze the memory behavior of Python objects
+ pkgver = 0.4
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/pympler/
+ arch = any
+ license = Apache
+ depends = python
+ source = http://pypi.python.org/packages/source/P/Pympler/Pympler-0.4.tar.gz
+ md5sums = 68e4a8aa4a268996fa6a321b664918af
+
+pkgname = python-pympler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24ab689c7502
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+
+pkgname=python-pympler
+pkgver=0.4
+pkgrel=1
+pkgdesc='Measure, monitor and analyze the memory behavior of Python objects'
+arch=('any')
+url='http://pypi.python.org/pypi/pympler/'
+license=('Apache')
+depends=('python')
+source=("http://pypi.python.org/packages/source/P/Pympler/Pympler-$pkgver.tar.gz")
+md5sums=('68e4a8aa4a268996fa6a321b664918af')
+
+build() {
+ cd "$srcdir/Pympler-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/Pympler-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+