summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavion2016-09-11 14:30:36 +1000
committerXavion2016-09-11 14:30:36 +1000
commit8e416ef41a9287ad05623b4bebd3172f9884c3ef (patch)
treef6d2402783189eec014ecdb3a1dfbdcb73cf0d5f
parentbb21662a2ba0df3595864c94a4fb37be61ab1875 (diff)
downloadaur-8e416ef41a9287ad05623b4bebd3172f9884c3ef.tar.gz
Initial package upload
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD41
2 files changed, 30 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1e2ba7a06b7..829b2aa63aec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Sep 11 04:29:35 UTC 2016
pkgbase = python-pympler
- pkgdesc = Measure, monitor and analyze the memory behavior of Python objects
+ pkgdesc = A development tool to measure, monitor and analyze the memory behavior of Python objects
pkgver = 0.4.3
pkgrel = 1
- url = http://pythonhosted.org/Pympler/
+ url = http://pypi.python.org/pypi/Pympler/
arch = any
- license = Apache2
- makedepends = python2-pip
- makedepends = python-pip
+ license = Apache
depends = python
- source = https://pypi.python.org/packages/7c/4d/7da5db3fa5939f661b92d46b3918ae57449a8522507e6562c586a7491d0e/Pympler-0.4.3.tar.gz
- md5sums = bbb4239126e9c99e2effc83b02bf8755
+ source = http://pypi.python.org/packages/source/P/Pympler/Pympler-0.4.3.tar.gz
+ sha1sums = 93f38f1b890b21b48955c532903909ecae5bce1b
pkgname = python-pympler
diff --git a/PKGBUILD b/PKGBUILD
index 25174a1759a8..1f1f27ffa2ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,28 @@
-# Maintainer: Christopher Loen <christopherloen at gmail dot com>
-# Contributor: Antony Lee <anntzer dot lee at gmail dot com>
+# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+# Contributor: XavierCLL
-pkgname='python-pympler'
-pkgver='0.4.3'
+pkgname=python-pympler
+_realname_=Pympler
+pkgver=0.4.3
pkgrel=1
-pkgdesc='Measure, monitor and analyze the memory behavior of Python objects'
-arch=('any')
-url='http://pythonhosted.org/Pympler/'
-license=('Apache2')
-depends=('python')
-makedepends=('python2-pip' 'python-pip')
-source=('https://pypi.python.org/packages/7c/4d/7da5db3fa5939f661b92d46b3918ae57449a8522507e6562c586a7491d0e/Pympler-0.4.3.tar.gz')
-md5sums=('bbb4239126e9c99e2effc83b02bf8755')
+pkgdesc="A development tool to measure, monitor and analyze the memory behavior of Python objects"
+url="http://pypi.python.org/pypi/${_realname_}/"
+arch=("any")
+license=("Apache")
+depends=("python")
+source=("http://pypi.python.org/packages/source/P/${_realname_}/${_realname_}-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}"/${_realname_}-${pkgver}
+
+ python setup.py build
+}
package() {
- cd "${srcdir}/Pympler-${pkgver}"
- echo :: Installing for python2.7 ...
- PIP_CONFIG_FILE=/dev/null pip2 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
- echo :: Installing for python3.5 ...
- PIP_CONFIG_FILE=/dev/null pip3 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}"/${_realname_}-${pkgver}
+
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ #install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+
+sha1sums=('93f38f1b890b21b48955c532903909ecae5bce1b')