summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-08-16 22:40:35 -0500
committerCarlos Aznarán Laos2022-08-16 22:40:35 -0500
commitf01e97328809e91205c95bc7ae7894658ebe11d8 (patch)
tree3e81fd6dda5d0301dcfa1230c75a864a38f0afda
parent3ca4ce583641cfaace07ece86edcc0c197069160 (diff)
downloadaur-f01e97328809e91205c95bc7ae7894658ebe11d8.tar.gz
Update license
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD35
2 files changed, 30 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d16128a9404..2997bdac20fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python-pymsgbox
- pkgdesc = Simple, cross-platform, pure Python module to display message boxes, and just message boxes.
+ pkgdesc = Simple, cross-platform, pure Python module to display message boxes, and just message boxes
pkgver = 1.0.9
pkgrel = 1
- url = https://github.com/asweigart/pymsgbox
+ url = https://github.com/asweigart/PyMsgBox
arch = any
- license = BSD
+ license = GPL3
makedepends = python-setuptools
+ depends = python
depends = tk
- source = https://pypi.python.org/packages/source/P/PyMsgBox/PyMsgBox-1.0.9.tar.gz
- md5sums = 007677929ce311e52e442dadb31ca669
+ source = https://pypi.org/packages/source/P/PyMsgBox/PyMsgBox-1.0.9.tar.gz
+ sha512sums = 929f2998aa5c26e238977815321911309eba64c3d9cbbe2354a02f9357e66c516cfb96b147b68fadbb543cf42d2060e7f2951a51f5f9f9af6cb8ea8da38a684e
pkgname = python-pymsgbox
diff --git a/PKGBUILD b/PKGBUILD
index 4b297b319f38..c942791b0b90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,31 @@
# Maintainer: Jose Riha <jose1711 gmail com>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
-pkgname=python-pymsgbox
+_base=PyMsgBox
+pkgname=python-${_base,,}
pkgver=1.0.9
pkgrel=1
-pkgdesc="Simple, cross-platform, pure Python module to display message boxes, and just message boxes."
-arch=("any")
-url="https://github.com/asweigart/pymsgbox"
-license=("BSD")
-makedepends=("python-setuptools")
-depends=("tk")
-source=(https://pypi.python.org/packages/source/P/PyMsgBox/PyMsgBox-${pkgver}.tar.gz)
-md5sums=('007677929ce311e52e442dadb31ca669')
+pkgdesc="Simple, cross-platform, pure Python module to display message boxes, and just message boxes"
+arch=(any)
+url="https://github.com/asweigart/${_base}"
+license=(GPL3)
+depends=(python tk)
+makedepends=(python-setuptools)
+# checkdepends=(python-pyautogui)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('929f2998aa5c26e238977815321911309eba64c3d9cbbe2354a02f9357e66c516cfb96b147b68fadbb543cf42d2060e7f2951a51f5f9f9af6cb8ea8da38a684e')
+
+build() {
+ cd ${_base}-${pkgver}
+ python setup.py build
+}
+
+# check() {
+# cd ${_base}-${pkgver}
+# PYTHONPATH="${PWD}/build/lib:${PYTHONPATH}" python tests/test_pymsgbox.py
+# }
package() {
- cd "$srcdir/PyMsgBox-${pkgver}"
- python setup.py install --prefix=/usr --root="$pkgdir"
+ cd ${_base}-${pkgver}
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}