summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-06 07:53:06 -0500
committerCarlos Aznarán Laos2023-05-06 07:53:06 -0500
commitf57eb2f99f16b6278cc4768789ff69669c660aad (patch)
tree76284665d8e69c93bc1b9345c37de5ce31d782df
parentf01e97328809e91205c95bc7ae7894658ebe11d8 (diff)
downloadaur-f57eb2f99f16b6278cc4768789ff69669c660aad.tar.gz
Python 3.11 rebuild
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2997bdac20fb..98ce1c51782b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-pymsgbox
pkgdesc = Simple, cross-platform, pure Python module to display message boxes, and just message boxes
pkgver = 1.0.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/asweigart/PyMsgBox
arch = any
license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
depends = tk
source = https://pypi.org/packages/source/P/PyMsgBox/PyMsgBox-1.0.9.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index c942791b0b90..222a6bb0624a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,20 @@
_base=PyMsgBox
pkgname=python-${_base,,}
pkgver=1.0.9
-pkgrel=1
+pkgrel=2
pkgdesc="Simple, cross-platform, pure Python module to display message boxes, and just message boxes"
arch=(any)
url="https://github.com/asweigart/${_base}"
license=(GPL3)
depends=(python tk)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-setuptools python-wheel)
# checkdepends=(python-pyautogui)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
sha512sums=('929f2998aa5c26e238977815321911309eba64c3d9cbbe2354a02f9357e66c516cfb96b147b68fadbb543cf42d2060e7f2951a51f5f9f9af6cb8ea8da38a684e')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
# check() {
@@ -27,5 +27,5 @@ build() {
package() {
cd ${_base}-${pkgver}
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
}