summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpozar2016-01-01 13:28:57 +0100
committerpozar2016-01-01 13:28:57 +0100
commit631ef4e33f1c22e2e9ff3dff25f9db160da25a25 (patch)
treecca35a7fa49a69043124276a071a96e182483313
parent5817d203531c23206f24b7f1c70f39816e799c19 (diff)
downloadaur-631ef4e33f1c22e2e9ff3dff25f9db160da25a25.tar.gz
add support for python and python2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 32 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25a259f37e78..5dc1cac153d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,26 @@
-pkgbase = python-pynbody-git
- pkgdesc = Pynbody is a light-weight, portable, format-transparent analysis framework for N-body and hydrodynamic astrophysical simulations.
- pkgver = 2139.dd026fd
+# Generated by mksrcinfo v8
+# Fri Jan 1 12:28:44 UTC 2016
+pkgbase = pynbody
+ pkgdesc = Pynbody is a light-weight, portable, format-transparent analysis framework for N-body and hydrodynamic astrophysical simulations
+ pkgver = 2163.ef932e7
pkgrel = 1
url = http://pynbody.github.io/
arch = any
license = MIT
makedepends = git
makedepends = cython>=0.2
- depends = python>=3.3
- depends = python-numpy
- depends = python-scipy
optdepends = python-matplotlib: plotting pynbody built-in plots
optdepends = ipython: makes using python much easier
source = pynbody::git://github.com/pynbody/pynbody.git#branch=master
md5sums = SKIP
pkgname = python-pynbody-git
+ depends = python>=3.3
+ depends = python-numpy
+ depends = python-scipy
+
+pkgname = python2-pynbody-git
+ depends = python2>=2.6
+ depends = python2-numpy
+ depends = python2-scipy
diff --git a/PKGBUILD b/PKGBUILD
index f8099dfaa5a6..e26fe80df2c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,15 @@
_gitname=pynbody
_gitbranch=master
-pkgname="python-${_gitname}-git"
-pkgdesc='Pynbody is a light-weight, portable, format-transparent analysis framework for N-body and hydrodynamic astrophysical simulations.'
-pkgver=2139.dd026fd
+pkgbase=pynbody
+pkgname=('python-pynbody-git'
+ 'python2-pynbody-git')
+pkgdesc='Pynbody is a light-weight, portable, format-transparent analysis framework for N-body and hydrodynamic astrophysical simulations'
+pkgver=2163.ef932e7
pkgrel=1
url="http://pynbody.github.io/"
license=('MIT')
arch=('any')
-depends=('python>=3.3'
- 'python-numpy'
- 'python-scipy')
makedepends=('git'
'cython>=0.2')
optdepends=('python-matplotlib: plotting pynbody built-in plots'
@@ -24,7 +23,19 @@ pkgver() {
echo "$(git rev-list --count ${_gitbranch}).$(git rev-parse --short ${_gitbranch})"
}
-package() {
- cd "${_gitname}"
+package_python-pynbody-git() {
+ depends=('python>=3.3'
+ 'python-numpy'
+ 'python-scipy')
+ cd "${srcdir}/${pkgbase}"
python setup.py install --root="${pkgdir}" --optimize=1
}
+
+package_python2-pynbody-git() {
+ depends=('python2>=2.6'
+ 'python2-numpy'
+ 'python2-scipy')
+ PYTHONPATH="/usr/lib/python2.7/site-packages"
+ cd "${srcdir}/${pkgbase}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}