summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorModelmat2020-01-06 13:28:48 +1100
committerModelmat2020-01-06 13:28:48 +1100
commit43df48b46d52c98975d56e7c3657a44a066a62c7 (patch)
tree12ca894c6b5907feac28830b810d47b7effd7efa
downloadaur-43df48b46d52c98975d56e7c3657a44a066a62c7.tar.gz
Adds python-pynetworktables project
-rw-r--r--.SRCINFO13
-rwxr-xr-x.gitignore6
-rwxr-xr-xPKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ea492339a7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-pynetworktables
+ pkgdesc = Pure python implementation of the FRC NetworkTables protocol
+ pkgver = 2019.0.2
+ pkgrel = 1
+ url = https://github.com/robotpy/pynetworktables
+ arch = x86_64
+ license = custom:FIRST
+ depends = python
+ source = python-pynetworktables::git+https://github.com/robotpy/pynetworktables#commit=e917bf34a5498c4bfaad6caab03658a92199bd55
+ md5sums = SKIP
+
+pkgname = python-pynetworktables
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..1e95ed76c214
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.tar
+python-pynetworktables/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..100f34508d1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Modelmat <modelmat@outlook.com.au>
+
+pkgname=python-pynetworktables
+_gitcommit=e917bf34a5498c4bfaad6caab03658a92199bd55
+pkgver=2019.0.2
+pkgrel=1
+pkgdesc="Pure python implementation of the FRC NetworkTables protocol"
+arch=("x86_64")
+url="https://github.com/robotpy/pynetworktables"
+license=("custom:FIRST")
+depends=("python")
+source=(${pkgname}::"git+https://github.com/robotpy/pynetworktables#commit=${_gitcommit}")
+md5sums=("SKIP")
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}