summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-10-09 16:45:09 -0400
committerGuillaume Horel2018-10-09 16:45:09 -0400
commit1416f1954a8e92011827cca7b222798a53316efe (patch)
tree20f2026de48b4a4147e4a78ef9872fd8057a1820
parent0f8ced45aec5c6fd7feb632b3cd81d28d66f2fad (diff)
downloadaur-1416f1954a8e92011827cca7b222798a53316efe.tar.gz
fix patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--new-api.patch41
3 files changed, 13 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fe50198e0bf..f3b006d20b35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = python-pynfft
source = https://pypi.org/packages/source/p/pyNFFT/pyNFFT-1.3.2.tar.gz
source = new-api.patch
sha256sums = ae41e720e569d0d99e3a44c82c36b35a49cfc9ecc23a1cd039fe9e2895aada2c
- sha256sums = 6eefe82a6e55bf776cd27550cca3317cc55c4062bed97253de192574cbc35dbb
+ sha256sums = d44f3144cd2ace01f021f67b724cd4036c37c9b1fbcf85521788875216666f0b
pkgname = python-pynfft
diff --git a/PKGBUILD b/PKGBUILD
index 01bc1a92e7a7..055743c5ac3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ makedepends=('cython')
source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
"new-api.patch")
sha256sums=('ae41e720e569d0d99e3a44c82c36b35a49cfc9ecc23a1cd039fe9e2895aada2c'
- '6eefe82a6e55bf776cd27550cca3317cc55c4062bed97253de192574cbc35dbb')
+ 'd44f3144cd2ace01f021f67b724cd4036c37c9b1fbcf85521788875216666f0b')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
diff --git a/new-api.patch b/new-api.patch
index 8b68cdf0aaa0..aa565c59e112 100644
--- a/new-api.patch
+++ b/new-api.patch
@@ -1,6 +1,6 @@
diff -urN pyNFFT-1.3.2-orig/pynfft/cnfft3util.pxd pyNFFT-1.3.2/pynfft/cnfft3util.pxd
---- pyNFFT-1.3.2-orig/pynfft/cnfft3util.pxd 2018-10-09 14:10:26.587955305 -0400
-+++ pyNFFT-1.3.2/pynfft/cnfft3util.pxd 2018-10-09 14:11:08.556960303 -0400
+--- pyNFFT-1.3.2-orig/pynfft/cnfft3util.pxd 2018-10-09 16:41:15.499575151 -0400
++++ pyNFFT-1.3.2/pynfft/cnfft3util.pxd 2018-10-09 16:41:38.394788488 -0400
@@ -17,7 +17,7 @@
from cnfft3 cimport fftw_complex
@@ -10,39 +10,20 @@ diff -urN pyNFFT-1.3.2-orig/pynfft/cnfft3util.pxd pyNFFT-1.3.2/pynfft/cnfft3util
void nfft_vrand_unit_complex (fftw_complex *x, int n)
# Inits a vector of random complex numbers in \
-@@ -25,10 +25,3 @@
-
- void nfft_vrand_shifted_unit_double (double *x, int n)
- # Inits a vector of random double numbers in $[-1/2,1/2]$ .
--
-- void nfft_voronoi_weights_1d (double *w, double *x, int M)
-- # Computes non periodic voronoi weights, \
-- # assumes ordered nodes $x_j$.
+@@ -29,6 +29,3 @@
+ void nfft_voronoi_weights_1d (double *w, double *x, int M)
+ # Computes non periodic voronoi weights, \
+ # assumes ordered nodes $x_j$.
-
- void nfft_voronoi_weights_S2(double *w, double *xi, int M)
- # Computes voronoi weights for nodes on the sphere S^2. */
diff -urN pyNFFT-1.3.2-orig/pynfft/util.pyx pyNFFT-1.3.2/pynfft/util.pyx
---- pyNFFT-1.3.2-orig/pynfft/util.pyx 2018-10-09 14:10:26.587955305 -0400
-+++ pyNFFT-1.3.2/pynfft/util.pyx 2018-10-09 14:10:50.296095301 -0400
-@@ -49,35 +49,3 @@
- '''
- nfft_vrand_shifted_unit_double(<double *>&x[0], x.size)
+--- pyNFFT-1.3.2-orig/pynfft/util.pyx 2018-10-09 16:41:15.499575151 -0400
++++ pyNFFT-1.3.2/pynfft/util.pyx 2018-10-09 16:42:25.604505154 -0400
+@@ -64,20 +64,3 @@
+ (%d, %d)'%(w.size, x.size))
+ nfft_voronoi_weights_1d(<double *>&w[0], <double *>&x[0], w.size)
--def voronoi_weights_1d (object[np.float64_t, mode='c'] w not None,
-- object[np.float64_t, mode='c'] x not None):
-- '''
-- Utilitary function for computing density compensation weights from 1D knots.
--
-- :param w: pre-allocated array
-- :type w: ndarray <float64>
-- :param x: ordered 1D knots
-- :type x: ndarray <float64>
-- '''
-- if x.size != w.size:
-- raise ValueError('Incompatible size between weights and nodes \
-- (%d, %d)'%(w.size, x.size))
-- nfft_voronoi_weights_1d(<double *>&w[0], <double *>&x[0], w.size)
--
-def voronoi_weights_S2 (object[np.float64_t, mode='c'] w not None,
- object[np.float64_t, mode='c'] xi not None):
- '''