summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-03-21 20:59:08 +0100
committerMichel Zou2020-03-21 20:59:08 +0100
commit7b460a4323706bc9d8a7f654409c6522553a1881 (patch)
tree78fec0428fc260a5c87737e22ba1a97337eb6fcf
downloadaur-7b460a4323706bc9d8a7f654409c6522553a1881.tar.gz
0.4.7
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f96020dc9297
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pynndescent
+ pkgdesc = Simple fast approximate nearest neighbor search
+ pkgver = 0.4.7
+ pkgrel = 1
+ url = http://github.com/lmcinnes/pynndescent
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-numba
+ depends = python-scikit-learn
+ source = https://pypi.io/packages/source/p/pynndescent/pynndescent-0.4.7.tar.gz
+ sha256sums = 391a19b8422a82e01141e7b82bd168632712a497856e6f4ff347e9a4f5c87565
+
+pkgname = python-pynndescent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8682921d0f1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=python-pynndescent
+pkgver=0.4.7
+pkgrel=1
+pkgdesc="Simple fast approximate nearest neighbor search"
+arch=('any')
+url="http://github.com/lmcinnes/pynndescent"
+license=('BSD')
+depends=('python-numba' 'python-scikit-learn')
+makedepends=('python-setuptools')
+source=("https://pypi.io/packages/source/p/pynndescent/pynndescent-${pkgver}.tar.gz")
+sha256sums=('391a19b8422a82e01141e7b82bd168632712a497856e6f4ff347e9a4f5c87565')
+
+package() {
+ cd "$srcdir/pynndescent-$pkgver"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}