summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuliette Monsel2020-01-09 10:33:43 +0100
committerJuliette Monsel2020-01-09 10:33:43 +0100
commit69580bda9e1a2cd03680470601e53b6d3f320f12 (patch)
treeba132cc7ab9d35abdc0da67aca35b34e734e6879
parent3ffcea19d317b84090567adc1286c0fc38e7c3f2 (diff)
downloadaur-69580bda9e1a2cd03680470601e53b6d3f320f12.tar.gz
New upstream release - v1.6.5
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1ab321818a6..7bc90056088e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-pynput
pkgdesc = Python library to monitor and control user input devices
- pkgver = 1.5.2
+ pkgver = 1.6.5
pkgrel = 1
url = https://github.com/moses-palmer/pynput
arch = any
license = LGPL3
makedepends = python-setuptools
+ makedepends = python-setuptools-lint
depends = python-xlib
depends = python-six
optdepends = python-sphinx: build online documentation
- source = python-pynput-1.5.2.tar.gz::https://github.com/moses-palmer/pynput/archive/v1.5.2.tar.gz
+ source = python-pynput-1.6.5.tar.gz::https://github.com/moses-palmer/pynput/archive/v1.6.5.tar.gz
source = python-pynput.patch
- sha512sums = 8aa54958bf5f48bdbda72f72c38f3302ddbfcde46c4d7fecf8e19f3ce2addecbd83993b97ce3012eda6ccc0b89157329e14b4c76022b4f832d39321bd253acda
+ sha512sums = 52ea1a36843ecfefbc2cb9fc96db29b90367bac06c4f6ecb16da1f6e7f9cde04ea0717927406ef110932974f3a010c4ca18924acc096ab914579ebcb9a0ba9f3
sha512sums = fd25744095c3201335cf601ec7e514f4bb2943de777849b2e821168d4e61098ecc355cfa13eb07ede7c1b91fe63f694a1dd42b13b5d4b8796a593aa5acf908b9
pkgname = python-pynput
diff --git a/PKGBUILD b/PKGBUILD
index b92e5c93e920..ed3912275f46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
pkgname='python-pynput'
-pkgver=1.5.2
+pkgver=1.6.5
pkgrel=1
_name=pynput
pkgdesc="Python library to monitor and control user input devices"
@@ -9,9 +9,9 @@ url="https://github.com/moses-palmer/pynput"
license=('LGPL3')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/moses-palmer/${_name}/archive/v${pkgver}.tar.gz"
"python-pynput.patch")
-sha512sums=('8aa54958bf5f48bdbda72f72c38f3302ddbfcde46c4d7fecf8e19f3ce2addecbd83993b97ce3012eda6ccc0b89157329e14b4c76022b4f832d39321bd253acda'
+sha512sums=('52ea1a36843ecfefbc2cb9fc96db29b90367bac06c4f6ecb16da1f6e7f9cde04ea0717927406ef110932974f3a010c4ca18924acc096ab914579ebcb9a0ba9f3'
'fd25744095c3201335cf601ec7e514f4bb2943de777849b2e821168d4e61098ecc355cfa13eb07ede7c1b91fe63f694a1dd42b13b5d4b8796a593aa5acf908b9')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-setuptools-lint')
depends=('python-xlib' 'python-six')
optdepends=('python-sphinx: build online documentation')
@@ -25,7 +25,7 @@ build() {
python setup.py build
}
-package_python-pynput() {
+package() {
cd "$srcdir/${_name}-${pkgver}"
python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build;
}