summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-09-09 17:14:16 +0200
committerMartino Pilia2018-09-09 17:14:16 +0200
commitf16acab4001da2d064458d03ca04446873fd8024 (patch)
tree5a857631ac9ba5d99602026bc108f78a929fa185
downloadaur-f16acab4001da2d064458d03ca04446873fd8024.tar.gz
package submission
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e8e3cb1f612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pynrrd
+ pkgdesc = Simple pure-python module for reading and writing nrrd files
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = https://github.com/mhe/pynrrd
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-numpy
+ source = https://github.com/mhe/pynrrd/archive/v0.3.2.tar.gz
+ sha256sums = 5c49d230c744cd0bd91934951d1db4a359aecf2c03312727cc4009d949ac893f
+
+pkgname = python-pynrrd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26b3451e195f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=pynrrd
+pkgname=python-$_pkgname
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="Simple pure-python module for reading and writing nrrd files"
+arch=('any')
+url="https://github.com/mhe/pynrrd"
+license=('MIT')
+depends=('python-numpy')
+optdepends=()
+makedepends=('python-setuptools')
+source=("https://github.com/mhe/pynrrd/archive/v${pkgver}.tar.gz")
+sha256sums=('5c49d230c744cd0bd91934951d1db4a359aecf2c03312727cc4009d949ac893f')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -D -m644 ${srcdir}/$_pkgname-$pkgver/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --optimize=1 --root=$pkgdir
+}