summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2021-12-30 23:09:32 -0600
committerKyle Manna2021-12-30 23:09:32 -0600
commit67126be7e9a02b46c879a7256ebf0fe77e0ee627 (patch)
tree11f8188a627eb0d718ed3de4aa0cd200d71727a3
downloadaur-67126be7e9a02b46c879a7256ebf0fe77e0ee627.tar.gz
release: 1.1.0
* Initial release.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..385ffb7bc6a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pyocd-pemicro
+ pkgdesc = Python On Chip Debugger and programmer for ARM Cortex-M microcontrollers using CMSIS-DAP
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/pyocd/pyocd-pemicro
+ arch = any
+ license = BSD-3-Clause
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pypemicro
+ source = https://github.com/pyocd/python-pyocd-pemicro/archive/v1.1.0.tar.gz
+ sha512sums = 7a9e6aca278d7c60d11836364d28b1a87d22779d0e31e40d108ce1b444b82c42f728c339735e8c327dbc513eb3617c4411280fb904bee29004567b6a6c0c117f
+
+pkgname = python-pyocd-pemicro
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bf83bab33f76
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.log
+/*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e73a89f0df0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
+_pkgname=pyocd-pemicro
+pkgname=python-$_pkgname
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Python On Chip Debugger and programmer for ARM Cortex-M microcontrollers using CMSIS-DAP"
+url="https://github.com/pyocd/pyocd-pemicro"
+depends=('python'
+ 'python-pypemicro'
+ )
+makedepends=('python-setuptools')
+license=('BSD-3-Clause')
+arch=('any')
+source=("https://github.com/pyocd/${pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('7a9e6aca278d7c60d11836364d28b1a87d22779d0e31e40d108ce1b444b82c42f728c339735e8c327dbc513eb3617c4411280fb904bee29004567b6a6c0c117f')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python3 setup.py install --root="$pkgdir" --optimize=1
+}
+