summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2021-12-30 23:28:59 -0600
committerKyle Manna2021-12-30 23:28:59 -0600
commitbf40a0036c3ef28833e36403a807d2682151472e (patch)
tree6c0cd338c3c4cedcb3d4233b16a24deef12f885b
parent67126be7e9a02b46c879a7256ebf0fe77e0ee627 (diff)
downloadaur-bf40a0036c3ef28833e36403a807d2682151472e.tar.gz
pkgrel 1.1.0-2
* Fetch from pypi so it has metdata.
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD6
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 385ffb7bc6a1..c7b541c8576f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = python-pyocd-pemicro
makedepends = python-setuptools
depends = python
depends = python-pypemicro
- source = https://github.com/pyocd/python-pyocd-pemicro/archive/v1.1.0.tar.gz
- sha512sums = 7a9e6aca278d7c60d11836364d28b1a87d22779d0e31e40d108ce1b444b82c42f728c339735e8c327dbc513eb3617c4411280fb904bee29004567b6a6c0c117f
+ source = https://pypi.python.org/packages/source/p/pyocd-pemicro/pyocd-pemicro-1.1.0.tar.gz
+ sha512sums = 1cb09b299436d4784523b77f66ec5c1d1114d38a71159ab73331c9530e7a77870f17dd9940f4bdcc7e1884139d4d3c987b48c92092e06ed57fe6938e40123384
pkgname = python-pyocd-pemicro
diff --git a/.gitignore b/.gitignore
index bf83bab33f76..9b0e523e106a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,4 @@
/*.log
/*.tar.*
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
index 0e73a89f0df0..404faef3ba81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=pyocd-pemicro
pkgname=python-$_pkgname
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python On Chip Debugger and programmer for ARM Cortex-M microcontrollers using CMSIS-DAP"
url="https://github.com/pyocd/pyocd-pemicro"
depends=('python'
@@ -11,8 +11,8 @@ depends=('python'
makedepends=('python-setuptools')
license=('BSD-3-Clause')
arch=('any')
-source=("https://github.com/pyocd/${pkgname}/archive/v${pkgver}.tar.gz")
-sha512sums=('7a9e6aca278d7c60d11836364d28b1a87d22779d0e31e40d108ce1b444b82c42f728c339735e8c327dbc513eb3617c4411280fb904bee29004567b6a6c0c117f')
+source=("https://pypi.python.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha512sums=('1cb09b299436d4784523b77f66ec5c1d1114d38a71159ab73331c9530e7a77870f17dd9940f4bdcc7e1884139d4d3c987b48c92092e06ed57fe6938e40123384')
build() {
cd "$srcdir/$_pkgname-$pkgver"