summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Land2022-07-19 03:48:45 -0500
committerGreg Land2022-07-19 03:48:45 -0500
commit9715f9fb263f9065e5079ed7522ea1be31f5999c (patch)
tree6cd403b67c23e8444a848a2437fe07bbceb46521
downloadaur-9715f9fb263f9065e5079ed7522ea1be31f5999c.tar.gz
added package back that was deleted
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8d3bac771b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-pyod
+ pkgdesc = A Python 3 Library Outlier Detection or Anomaly Detection
+ pkgver = 0.8.3
+ pkgrel = 1
+ url = https://github.com/yzhao062/pyod
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/yzhao062/pyod/archive/V0.8.3.tar.gz
+ sha512sums = 486a491ae50ae0acdc9eabba319c101f871534913c7ea518a0bacf7589e8ebaabaf795d4dfeec025cbabeabc23dc9a11aff1c0c58bf4fed5d7b93b9d0bfe0e6b
+
+pkgname = python-pyod
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..455acce19eb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_name=pyod
+pkgname="python-$_name"
+pkgver=0.8.3
+pkgrel=1
+arch=('any')
+pkgdesc="A Python 3 Library Outlier Detection or Anomaly Detection"
+url="https://github.com/yzhao062/pyod"
+license=('GPL3')
+source=("https://github.com/yzhao062/pyod/archive/V$pkgver.tar.gz")
+sha512sums=('486a491ae50ae0acdc9eabba319c101f871534913c7ea518a0bacf7589e8ebaabaf795d4dfeec025cbabeabc23dc9a11aff1c0c58bf4fed5d7b93b9d0bfe0e6b')
+depends=(
+ 'python'
+)
+makedepends=('python-setuptools')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}