summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetRUShka2015-07-01 17:33:32 +0300
committerpetRUShka2015-07-01 17:33:32 +0300
commita71f1b712cf5892efc9b0cc055cac86661f7d91e (patch)
tree715af35746e76ee1f5252e0d2fabf628c1447338
downloadaur-a71f1b712cf5892efc9b0cc055cac86661f7d91e.tar.gz
Initial import
-rw-r--r--.SRCINFO35
-rw-r--r--LICENSE.txt20
-rw-r--r--PKGBUILD94
3 files changed, 149 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfdb8265a07a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = python-pyopencl-git
+ pkgdesc = A complete, object-oriented language binding of OpenCL to Python
+ pkgver = 20130125
+ pkgrel = 4
+ url = http://mathema.tician.de/software/pyopencl
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = ctags
+ makedepends = python2-distribute
+ makedepends = python-distribute
+ makedepends = libcl
+ makedepends = opencl-headers
+ makedepends = mesa
+ makedepends = boost
+ makedepends = python2-mako
+ makedepends = python-mako
+ makedepends = python-numpy
+ makedepends = python2-numpy
+ source = LICENSE.txt
+ sha1sums = 2e6966b3d9b15603ce2c3ff79eeadd63c5d066b7
+
+pkgname = python-pyopencl-git
+ depends = libcl
+ depends = opencl-headers
+ depends = mesa
+ depends = boost
+ depends = python
+ depends = python-numpy
+ depends = python-mako
+ depends = python-pytools
+ depends = pyopencl-headers-git
+ provides = python-pyopencl
+ conflicts = python-pyopencl
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..3ce400f9d926
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,20 @@
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation
+files (the "Software"), to deal in the Software without
+restriction, including without limitation the rights to use,
+copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54c3f0ef9078
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,94 @@
+# $Id: PKGBUILD 82124 2013-01-09 01:12:19Z stephane $
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+
+#pkgbase=python-pyopencl-git
+#pkgname=('python2-pyopencl-git' 'python-pyopencl-git' 'pyopencl-headers-git')
+pkgname=('python-pyopencl-git')
+#pkgname=('python2-pyopencl-git')
+#pkgname=('pyopencl-headers-git')
+pkgver=20130125
+pkgrel=4
+pkgdesc="A complete, object-oriented language binding of OpenCL to Python"
+arch=('i686' 'x86_64')
+url="http://mathema.tician.de/software/pyopencl"
+license=('custom')
+makedepends=('ctags' 'python2-distribute' 'python-distribute' 'libcl' 'opencl-headers' 'mesa' 'boost' 'python2-mako' 'python-mako' 'python-numpy' 'python2-numpy')
+source=('LICENSE.txt')
+sha1sums=('2e6966b3d9b15603ce2c3ff79eeadd63c5d066b7')
+
+_gitroot='git://github.com/inducer/pyopencl.git'
+_gitname='pyopencl_cache'
+
+build() {
+ msg 'Connecting to github GIT server....'
+
+ if [ -d $_gitname ] ; then
+ pushd $_gitname
+ git pull origin
+ popd
+ msg 'The local files are updated.'
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg 'GIT checkout done or server timeout'
+
+ cd $_gitname
+
+ git submodule update --init
+
+ cd ${srcdir}
+
+ for build in pyopencl pyopencl-python2
+ do
+ [ -d $build ] && rm -rf $build
+ cp -r $_gitname $build
+ done
+
+ msg 'Starting make...'
+
+ cd "${srcdir}/pyopencl"
+ python3 ./configure.py --cl-enable-gl --no-use-shipped-boost --boost-python-libname=boost_python3
+ python3 setup.py build
+
+ cd "$srcdir/pyopencl-python2"
+ python2 ./configure.py --cl-enable-gl --no-use-shipped-boost
+ python2 setup.py build
+}
+
+package_python-pyopencl-git() {
+ depends=('libcl' 'opencl-headers' 'mesa' 'boost' 'python' 'python-numpy' 'python-mako' 'python-pytools' 'pyopencl-headers-git')
+ provides=('python-pyopencl')
+ conflicts=('python-pyopencl')
+
+ cd "${srcdir}/pyopencl"
+ python3 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+
+ rm -fr "${pkgdir}"/usr/include
+
+ install -D -m644 ../LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+
+package_python2-pyopencl-git() {
+ depends=('libcl' 'opencl-headers' 'mesa' 'boost' 'python2' 'python2-numpy' 'python2-mako' 'python2-pytools' 'pyopencl-headers-git')
+ provides=('python2-pyopencl')
+ conflicts=('python2-pyopencl')
+
+ cd "${srcdir}/pyopencl-python2"
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+
+ rm -fr "${pkgdir}"/usr/include
+
+ install -D -m644 ../LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+
+package_pyopencl-headers-git() {
+ provides=('pyopencl-headers')
+ conflicts=('pyopencl-headers')
+ cd "${srcdir}/pyopencl"
+ install -dm755 "${pkgdir}"/usr/include/pyopencl
+
+ for file in src/cl/*.{h,cl}; do
+ install -m644 ${file} "${pkgdir}"/usr/include/pyopencl
+ done
+}