summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2022-02-21 20:39:01 -0600
committerkyechou2022-02-21 20:39:01 -0600
commit96856cca42e17037e2daf996778918ab5dc9b87b (patch)
treef9ae971ee67ac44cce376f07ff6eb92c9c657ba9
downloadaur-96856cca42e17037e2daf996778918ab5dc9b87b.tar.gz
Initial commit v5.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3a21849073f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pypacker
+ pkgdesc = The fastest and simplest packet manipulation lib for Python
+ pkgver = 5.1
+ pkgrel = 1
+ url = https://gitlab.com/mike01/pypacker
+ arch = x86_64
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-netifaces
+ source = https://gitlab.com/mike01/pypacker/-/archive/v5.1/pypacker-v5.1.tar.gz
+ sha256sums = 4d282e2533952e3d4f8aad66898e1db4d23c7cd23692415d70a5237db641e312
+
+pkgname = python-pypacker
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2168c9f8a3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Kuan-Yen Chou <kuanyenchou at gmail dot com>
+
+pkgname=python-pypacker
+pkgver=5.1
+pkgrel=1
+pkgdesc="The fastest and simplest packet manipulation lib for Python"
+arch=('x86_64')
+url="https://gitlab.com/mike01/pypacker"
+license=('GPL')
+depends=('python' 'python-netifaces')
+makedepends=('python-setuptools')
+source=("https://gitlab.com/mike01/pypacker/-/archive/v$pkgver/pypacker-v$pkgver.tar.gz")
+sha256sums=('4d282e2533952e3d4f8aad66898e1db4d23c7cd23692415d70a5237db641e312')
+
+build() {
+ cd "$srcdir/pypacker-v$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/pypacker-v$pkgver"
+ python setup.py install \
+ --prefix=/usr \
+ --root="$pkgdir" \
+ --optimize=1 \
+ --skip-build
+}
+
+# vim: set ts=4 sw=4 et :