summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-11-20 22:34:54 -0500
committerCarlos Aznarán2023-11-20 22:34:54 -0500
commit421be4c15aedf1d995b4eabcf088e137e0b06744 (patch)
tree6e450495a6138196c14b10a437f79a118ab7e89e
parent6b4ce8dc1d65d2420ebbdb092ac4f67f2852ab22 (diff)
downloadaur-421be4c15aedf1d995b4eabcf088e137e0b06744.tar.gz
Bump version to 0.4.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c8f8dd63665..d0e2a7d017b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pypardiso
pkgdesc = Python interface to the Intel MKL Pardiso library to solve large sparse linear systems of equations
- pkgver = 0.4.3
+ pkgver = 0.4.4
pkgrel = 1
url = https://github.com/haasad/PyPardisoProject
arch = any
@@ -8,11 +8,11 @@ pkgbase = python-pypardiso
checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
- makedepends = python-setuptools
+ makedepends = python-setuptools-scm
makedepends = python-wheel
depends = intel-oneapi-mkl
depends = python-scipy
- source = PyPardisoProject-0.4.3.tar.gz::https://github.com/haasad/PyPardisoProject/archive/v0.4.3.tar.gz
- sha512sums = 4ced5d056f707ab282e77550fb1d36d68eb80a090e8cf2e8f5ce37797dcbd31460ead1a17e86ae42e7922d1741d01437b7482fc31c2f9c5a3240767a57d9e263
+ source = PyPardisoProject-0.4.4.tar.gz::https://github.com/haasad/PyPardisoProject/archive/v0.4.4.tar.gz
+ sha512sums = 0ccabdeda5357c555473b35eb5245f445d3feec13b8647556a5ff08fc19c5f8c4d6bafc14af89f9b6bb080040c7b5217d107dd7f0b4ea33ae25ceef62ababefa
pkgname = python-pypardiso
diff --git a/PKGBUILD b/PKGBUILD
index 824e59f52ec6..96d7dd0e9084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=PyPardiso
pkgname=python-${_base,,}
-pkgver=0.4.3
+pkgver=0.4.4
pkgrel=1
pkgdesc="Python interface to the Intel MKL Pardiso library to solve large sparse linear systems of equations"
arch=(any)
url="https://github.com/haasad/${_base}Project"
license=('custom:BSD-3-clause')
depends=(intel-oneapi-mkl python-scipy)
-makedepends=(python-build python-installer python-setuptools python-wheel)
+makedepends=(python-build python-installer python-setuptools-scm python-wheel)
checkdepends=(python-pytest)
source=(${_base}Project-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('4ced5d056f707ab282e77550fb1d36d68eb80a090e8cf2e8f5ce37797dcbd31460ead1a17e86ae42e7922d1741d01437b7482fc31c2f9c5a3240767a57d9e263')
+sha512sums=('0ccabdeda5357c555473b35eb5245f445d3feec13b8647556a5ff08fc19c5f8c4d6bafc14af89f9b6bb080040c7b5217d107dd7f0b4ea33ae25ceef62ababefa')
build() {
cd ${_base}Project-${pkgver}
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
}