summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-08-17 12:11:00 -0500
committerCarlos Aznarán Laos2023-08-17 12:11:00 -0500
commita72e130e37b8c4b3d6a0ea30ada043bf98c172ad (patch)
treed19012d2472403bbbd3aba4746b96d18b9d9dda4
parentf549fc5c36e11da71a3f5912072c839f52002af3 (diff)
downloadaur-a72e130e37b8c4b3d6a0ea30ada043bf98c172ad.tar.gz
Support SciPy 1.11 or later
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02c46bad29ee..2d45b0bae968 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = python-pypardiso
pkgdesc = Python interface to the Intel MKL Pardiso library to solve large sparse linear systems of equations
pkgver = 0.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/haasad/PyPardisoProject
- arch = x86_64
+ arch = any
license = custom:BSD-3-clause
checkdepends = python-pytest
makedepends = python-build
@@ -12,7 +12,9 @@ pkgbase = python-pypardiso
makedepends = python-wheel
depends = intel-oneapi-mkl
depends = python-scipy
- source = pypardiso-0.4.2.tar.gz::https://github.com/haasad/PyPardisoProject/archive/v0.4.2.tar.gz
+ source = PyPardisoProject-0.4.2.tar.gz::https://github.com/haasad/PyPardisoProject/archive/v0.4.2.tar.gz
+ source = unsorted_indices.patch::https://github.com/haasad/PyPardisoProject/commit/a591a30832a1250fb31ca64a4903d50bca8de733.patch
sha512sums = defc59769f40447099260f4f9ef9b6707f3c09708275f74fedc44226faa259a7d41b39aaefd36c203a6eb2623167f7fde6404d7d96d551ac9001e3b6c69dd1ef
+ sha512sums = eff0ddae42e22bb3f4922b01ce384169ad3afd6a76a98e91869b79ed8b60c8842d3981c0f742e79ef90e587f5ee7af923fc27c044c64e2c1a0fed5f7c8d5b53f
pkgname = python-pypardiso
diff --git a/PKGBUILD b/PKGBUILD
index fcec5dc72517..3c6896b5bb6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,39 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
-_base=pypardiso
-pkgname=python-${_base}
+_base=PyPardiso
+pkgname=python-${_base,,}
pkgver=0.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="Python interface to the Intel MKL Pardiso library to solve large sparse linear systems of equations"
-arch=('x86_64')
-url="https://github.com/haasad/PyPardisoProject"
+arch=(any)
+url="https://github.com/haasad/${_base}Project"
license=('custom:BSD-3-clause')
depends=(intel-oneapi-mkl python-scipy)
makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(python-pytest)
-source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('defc59769f40447099260f4f9ef9b6707f3c09708275f74fedc44226faa259a7d41b39aaefd36c203a6eb2623167f7fde6404d7d96d551ac9001e3b6c69dd1ef')
+source=(${_base}Project-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz
+ unsorted_indices.patch::${url}/commit/a591a30832a1250fb31ca64a4903d50bca8de733.patch)
+sha512sums=('defc59769f40447099260f4f9ef9b6707f3c09708275f74fedc44226faa259a7d41b39aaefd36c203a6eb2623167f7fde6404d7d96d551ac9001e3b6c69dd1ef'
+ 'eff0ddae42e22bb3f4922b01ce384169ad3afd6a76a98e91869b79ed8b60c8842d3981c0f742e79ef90e587f5ee7af923fc27c044c64e2c1a0fed5f7c8d5b53f')
+
+prepare() {
+ cd ${_base}Project-${pkgver}
+ patch -p1 -i ../unsorted_indices.patch
+}
build() {
- cd PyPardisoProject-${pkgver}
+ cd ${_base}Project-${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd PyPardisoProject-${pkgver}
+ cd ${_base}Project-${pkgver}
python -m venv --system-site-packages test-env
test-env/bin/python -m installer dist/*.whl
test-env/bin/python -m pytest tests
}
package() {
- cd PyPardisoProject-${pkgver}
+ cd ${_base}Project-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}