summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-03-28 23:49:54 -0500
committerCarlos Aznarán2024-03-28 23:49:54 -0500
commitedb2c49bafecbc88283cd42e199bb1dd46363cc7 (patch)
tree9dfe624694c3fc739c63812dc4ade7cd3b8ca32d
parentdf18237c1104c84eca5d3b8b4e38ef66f84e305d (diff)
downloadaur-edb2c49bafecbc88283cd42e199bb1dd46363cc7.tar.gz
Bump version to 0.4.6
-rw-r--r--.SRCINFO8
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD6
3 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 401b482e537c..92a3a56f2235 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-pypardiso
pkgdesc = Python interface to the Intel MKL Pardiso library to solve large sparse linear systems of equations
- pkgver = 0.4.5
+ pkgver = 0.4.6
pkgrel = 1
url = https://github.com/haasad/PyPardisoProject
arch = any
- license = BSD-3-clause
+ license = BSD-3-Clause
checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
@@ -12,7 +12,7 @@ pkgbase = python-pypardiso
makedepends = python-wheel
depends = intel-oneapi-mkl
depends = python-scipy
- source = PyPardisoProject-0.4.5.tar.gz::https://github.com/haasad/PyPardisoProject/archive/v0.4.5.tar.gz
- sha512sums = e5e20d6d35c7626bf64d9c9e5f5012e57fed6799150903f5b22c0c90f55ae91c09522e3344e280e16ca901a8682c65fff1813a81ae8ad7dfc121a5c8d39d3a0f
+ source = PyPardisoProject-0.4.6.tar.gz::https://github.com/haasad/PyPardisoProject/archive/v0.4.6.tar.gz
+ sha512sums = 201420ce934b6c3ecdb0833df448fc8682920c7e9699ccbe77dda2fb66e4373218b06be77cd7d0ac872e890b8e6e53af38cc03040f4ee7aedb36b7af7f783687
pkgname = python-pypardiso
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..fd23aab83038
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[python-pypardiso]
+source = "github"
+github = "haasad/PyPardisoProject"
+use_latest_release = "true"
+prefix = "v" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index cc41a0f325f7..b0f869b333a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=PyPardiso
pkgname=python-${_base,,}
-pkgver=0.4.5
+pkgver=0.4.6
pkgrel=1
pkgdesc="Python interface to the Intel MKL Pardiso library to solve large sparse linear systems of equations"
arch=(any)
url="https://github.com/haasad/${_base}Project"
-license=(BSD-3-clause)
+license=(BSD-3-Clause)
depends=(intel-oneapi-mkl python-scipy)
makedepends=(python-build python-installer python-setuptools-scm python-wheel)
checkdepends=(python-pytest)
source=(${_base}Project-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('e5e20d6d35c7626bf64d9c9e5f5012e57fed6799150903f5b22c0c90f55ae91c09522e3344e280e16ca901a8682c65fff1813a81ae8ad7dfc121a5c8d39d3a0f')
+sha512sums=('201420ce934b6c3ecdb0833df448fc8682920c7e9699ccbe77dda2fb66e4373218b06be77cd7d0ac872e890b8e6e53af38cc03040f4ee7aedb36b7af7f783687')
build() {
cd ${_base}Project-${pkgver}