summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-04-06 22:24:49 +0200
committerPhilip Goto2020-04-06 22:24:49 +0200
commit092e132689491f3f0de7a009ca132f59deb98b92 (patch)
treea0c97e7c728b49e91b375097664dfdcf93e2d041
downloadaur-092e132689491f3f0de7a009ca132f59deb98b92.tar.gz
Initialize package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4352510b120
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pypcd
+ pkgdesc = Pure Python module to read and write point clouds stored in the PCD file format, used by the Point Cloud Library
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/dimatura/pypcd
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/99/c5/f0b3003d36f50bb084c887e5277ceff0c7671f92690c8a69910b21a2519f/pypcd-0.1.1.tar.gz
+ sha256sums = 32a14d37ffbfd4efe7a10191f26581c48986208ac9a1fdd02f25a6dfa9b144c2
+
+pkgname = python-pypcd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c87528a64398
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=python-pypcd
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Pure Python module to read and write point clouds stored in the PCD file format, used by the Point Cloud Library"
+url="https://github.com/dimatura/pypcd"
+depends=(python)
+makedepends=(python-setuptools)
+license=("BSD")
+arch=(any)
+source=("https://files.pythonhosted.org/packages/99/c5/f0b3003d36f50bb084c887e5277ceff0c7671f92690c8a69910b21a2519f/pypcd-0.1.1.tar.gz")
+sha256sums=('32a14d37ffbfd4efe7a10191f26581c48986208ac9a1fdd02f25a6dfa9b144c2')
+
+
+prepare() {
+ cd "pypcd-${pkgver}"
+ touch HISTORY.rst
+}
+
+build() {
+ cd "pypcd-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "pypcd-${pkgver}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+}