summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2022-07-21 10:35:09 +1000
committerMark Blakeney2022-07-21 10:37:01 +1000
commit0e25bd24244bc9f73fd4e4787a8c5c99c6a384f1 (patch)
tree15ded8e36b8feb4a178fdaca24155a36f759126d
parent7bfae1ad1f0a266516423e17b7d5c4257a2732e6 (diff)
downloadaur-0e25bd24244bc9f73fd4e4787a8c5c99c6a384f1.tar.gz
Update to 2.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3c8e51da03a..1ec4b18ac49e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-pypdf2
- pkgdesc = A pure-python PDF library capable of splitting, merging, cropping, and transforming the pages of PDF files
- pkgver = 1.27.12
+ pkgdesc = A pure-python PDF library for splitting, merging, cropping, and transforming pages of PDF files
+ pkgver = 2.6.0
pkgrel = 1
url = https://github.com/py-pdf/PyPDF2
arch = any
license = BSD
makedepends = python-setuptools
depends = python
- source = python-pypdf2-1.27.12.tar.gz::https://github.com/py-pdf/PyPDF2/archive/1.27.12.tar.gz
- sha256sums = 2f953639cc0c2722aac61411c4ba4f03116825946c13cc9d01500a183862632c
+ source = python-pypdf2-2.6.0.tar.gz::https://github.com/py-pdf/PyPDF2/archive/2.6.0.tar.gz
+ sha256sums = 24848d28fb84caf793b7e465032a39747bf9484488c095a36b95e7608f650c56
pkgname = python-pypdf2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad6fbda9f142
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar
+*.tar.*
+*.[gx]z
diff --git a/PKGBUILD b/PKGBUILD
index 8d97e2dee1c3..4c92f414cddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Maintainer: Yuanji <self@gimo.me>
+# Maintainer: mark.blakeney at bullet-systems dot net
+# Contributor: Yuanji <self@gimo.me>
# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Francois Boulogne <fboulogne at april dot org>
+_name=PyPDF2
pkgname=python-pypdf2
-pkgver=1.27.12
+pkgver=2.6.0
pkgrel=1
-pkgdesc='A pure-python PDF library capable of splitting, merging, cropping, and transforming the pages of PDF files'
+pkgdesc='A pure-python PDF library for splitting, merging, cropping, and transforming pages of PDF files'
arch=(any)
-url='https://github.com/py-pdf/PyPDF2'
+url="https://github.com/py-pdf/$_name"
license=(BSD)
depends=(python)
makedepends=(python-setuptools)
-source=($pkgname-$pkgver.tar.gz::"https://github.com/py-pdf/PyPDF2/archive/$pkgver.tar.gz")
-sha256sums=('2f953639cc0c2722aac61411c4ba4f03116825946c13cc9d01500a183862632c')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/py-pdf/$_name/archive/$pkgver.tar.gz")
+sha256sums=('24848d28fb84caf793b7e465032a39747bf9484488c095a36b95e7608f650c56')
build() {
- cd PyPDF2-$pkgver
+ cd $_name-$pkgver
python setup.py build
}
package(){
- cd PyPDF2-$pkgver
+ cd $_name-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
- install -D -m755 Scripts/pdfcat "$pkgdir"/usr/bin/pdfcat
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}