summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2022-10-09 20:14:24 +1000
committerMark Blakeney2022-10-09 20:14:24 +1000
commit6faefd18bc46575992679395ad968fbb376b4d49 (patch)
treee2a2ee2c694bac1a7ff38225f242860d01e7c501
parent070ef460edbabb0c686f679167071cca09bac579 (diff)
downloadaur-6faefd18bc46575992679395ad968fbb376b4d49.tar.gz
Update to 2.11.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5d4d4d46c49..7da920ba8d46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-pypdf2
pkgdesc = Python library for splitting, merging, cropping, and transforming pages of PDF files
- pkgver = 2.11.0
+ pkgver = 2.11.1
pkgrel = 1
url = https://github.com/py-pdf/PyPDF2
arch = any
license = BSD
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- source = python-pypdf2-2.11.0.tar.gz::https://github.com/py-pdf/PyPDF2/archive/2.11.0.tar.gz
- sha256sums = 0f6fa92bae50f1457c14db3e4ff432a85cfb115959cf2c3718de562261e4709d
+ source = python-pypdf2-2.11.1.tar.gz::https://github.com/py-pdf/PyPDF2/archive/2.11.1.tar.gz
+ sha256sums = a4e323120adc5103d53c370782bfc86381143ea7b69e9213eb1263c7aaf39df8
pkgname = python-pypdf2
diff --git a/PKGBUILD b/PKGBUILD
index 448ee5e38fe0..544817bef5a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,24 @@
_name=PyPDF2
pkgname=python-pypdf2
-pkgver=2.11.0
+pkgver=2.11.1
pkgrel=1
pkgdesc='Python library for splitting, merging, cropping, and transforming pages of PDF files'
arch=(any)
url="https://github.com/py-pdf/$_name"
license=(BSD)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-wheel)
source=($pkgname-$pkgver.tar.gz::"https://github.com/py-pdf/$_name/archive/$pkgver.tar.gz")
-sha256sums=('0f6fa92bae50f1457c14db3e4ff432a85cfb115959cf2c3718de562261e4709d')
+sha256sums=('a4e323120adc5103d53c370782bfc86381143ea7b69e9213eb1263c7aaf39df8')
build() {
cd $_name-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package(){
cd $_name-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}