summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2022-12-23 12:05:14 +1000
committerMark Blakeney2022-12-23 12:05:46 +1000
commitb622e7fe1bf66d26b3202d21b48ba0ed615ed1fb (patch)
treee8ec6811d3d304060a36094f70cf631816110310
parent5d0f460288b864597707642c7130a7c00496917c (diff)
downloadaur-b622e7fe1bf66d26b3202d21b48ba0ed615ed1fb.tar.gz
Update to 3.0.0-2
Fix PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bec9828278f1..9b5778d21243 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pypdf2
pkgdesc = Python library for splitting, merging, cropping, and transforming pages of PDF files
pkgver = 3.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/py-pdf/PyPDF2
arch = any
license = BSD
@@ -12,6 +12,6 @@ pkgbase = python-pypdf2
makedepends = python-flit-core
depends = python
source = python-pypdf2-3.0.0.tar.gz::https://github.com/py-pdf/PyPDF2/archive/3.0.0.tar.gz
- sha256sums = 25952ff26f08213d9e8aeb22543bef909ba2a5defe28942dd281881e76cc6630
+ sha256sums = 1f7bfaa7d8e596a445fe0c990cbc7325fefe40b079816585aeacc6d169c82c24
pkgname = python-pypdf2
diff --git a/PKGBUILD b/PKGBUILD
index b9df5323b827..f8e3045648a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_name=PyPDF2
pkgname=python-pypdf2
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Python library for splitting, merging, cropping, and transforming pages of PDF files'
arch=(any)
url="https://github.com/py-pdf/$_name"
@@ -14,15 +14,15 @@ license=(BSD)
depends=(python)
makedepends=(python-setuptools python-build python-installer python-wheel python-flit-core)
source=($pkgname-$pkgver.tar.gz::"$url/archive/$pkgver.tar.gz")
-sha256sums=('25952ff26f08213d9e8aeb22543bef909ba2a5defe28942dd281881e76cc6630')
+sha256sums=('1f7bfaa7d8e596a445fe0c990cbc7325fefe40b079816585aeacc6d169c82c24')
build() {
- cd $_name-$pkgver
+ cd pypdf-$pkgver
python -m build --wheel --no-isolation
}
package(){
- cd $_name-$pkgver
+ cd pypdf-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}