summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2022-12-24 13:23:46 +1000
committerMark Blakeney2022-12-24 13:23:46 +1000
commitc4e737184ef09c022e53d4351f1c6edcf20e652a (patch)
treed1b5842acfc64c9f59199ed229d2fb97971d548e
parente137dfe392a01b483de859a0311190ed03703774 (diff)
downloadaur-c4e737184ef09c022e53d4351f1c6edcf20e652a.tar.gz
Restore back to version 2.12.1
New v3+ version will be packaged as python-pypdf
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d14148ea061..cd7fdb81828a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = python-pypdf2
- pkgdesc = Python library for splitting, merging, cropping, and transforming pages of PDF files
- pkgver = 3.1.0
- pkgrel = 1
+ pkgdesc = Python library for manipulating pages of PDF files (legacy v2)
+ pkgver = 2.12.1
+ pkgrel = 2
+ epoch = 1
url = https://github.com/py-pdf/PyPDF2
arch = any
license = BSD
@@ -11,7 +12,7 @@ pkgbase = python-pypdf2
makedepends = python-wheel
makedepends = python-flit-core
depends = python
- source = python-pypdf2-3.1.0.tar.gz::https://github.com/py-pdf/PyPDF2/archive/3.1.0.tar.gz
- sha256sums = 9c34f31b6a54076b779245f48ce25622a9b70f739c667e5e7bd1e19f207949e7
+ source = python-pypdf2-2.12.1.tar.gz::https://github.com/py-pdf/PyPDF2/archive/2.12.1.tar.gz
+ sha256sums = 40743764b367c43357546fd10d39f288a3a9c520e043f75eea7a1b78ccc38d3f
pkgname = python-pypdf2
diff --git a/PKGBUILD b/PKGBUILD
index f6e9ea695ac4..61b1fac21cd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,31 @@
# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Francois Boulogne <fboulogne at april dot org>
+_name=PyPDF2
pkgname=python-pypdf2
-pkgver=3.1.0
-pkgrel=1
-pkgdesc='Python library for splitting, merging, cropping, and transforming pages of PDF files'
+pkgver=2.12.1
+pkgrel=2
+epoch=1
+pkgdesc='Python library for manipulating pages of PDF files (legacy v2)'
arch=(any)
-url="https://github.com/py-pdf/PyPDF2"
+url="https://github.com/py-pdf/$_name"
license=(BSD)
depends=(python)
makedepends=(python-setuptools python-build python-installer python-wheel python-flit-core)
source=($pkgname-$pkgver.tar.gz::"$url/archive/$pkgver.tar.gz")
-sha256sums=('9c34f31b6a54076b779245f48ce25622a9b70f739c667e5e7bd1e19f207949e7')
+sha256sums=('40743764b367c43357546fd10d39f288a3a9c520e043f75eea7a1b78ccc38d3f')
build() {
- cd pypdf-$pkgver
+ cd $_name-$pkgver
python -m build --wheel --no-isolation
}
+prepare() {
+ mv pypdf-$pkgver $_name-$pkgver
+}
+
package(){
- cd pypdf-$pkgver
+ cd $_name-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}