summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Oliver Oelerich2015-06-09 08:49:44 +0200
committerJan Oliver Oelerich2015-06-09 08:49:44 +0200
commita5845b251f725a709f94bde7eb5ec1c913d3eda5 (patch)
tree80d900abffb1e343a70a4f2beb0947473e826dce
downloadaur-a5845b251f725a709f94bde7eb5ec1c913d3eda5.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..978edbfbb76e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pypdf2-git
+ pkgdesc = PyPDF2 library for Python3
+ pkgver = b17382f
+ pkgrel = 1
+ url = http://mstamy2.github.com/PyPDF2
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ conflicts = python-pypdf-git
+ source = git+https://github.com/mstamy2/PyPDF2.git
+ md5sums = SKIP
+
+pkgname = python-pypdf2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd6c6d3e2ad2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jan Oliver Oelerich <janoliver@oelerich.org>
+pkgname=python-pypdf2-git
+pkgver=b17382f
+pkgrel=1
+pkgdesc="PyPDF2 library for Python3"
+arch=('i686' 'x86_64')
+url="http://mstamy2.github.com/PyPDF2"
+license=('custom')
+depends=('python')
+conflicts=('python-pypdf-git')
+makedepends=('git' 'python-setuptools')
+source=('git+https://github.com/mstamy2/PyPDF2.git')
+_gitname="PyPDF2"
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git describe --always --long | sed 's/^[v]//;s/-/-r/' | tr - .)
+}
+
+build() {
+ :
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}