summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2021-03-10 16:48:15 +0100
committerHans-Nikolai Viessmann2021-03-10 16:48:15 +0100
commit03d05c9e0cb91e1485b552e5a3d267ecf93c001f (patch)
tree1e1c595c757953304fabb4171f3e55cd0f73a1f3
downloadaur-03d05c9e0cb91e1485b552e5a3d267ecf93c001f.tar.gz
initial commit; version 1.0.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60d5e2b588ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pypdf3
+ pkgdesc = Pure-Python PDF library for splitting, merging, cropping, and transforming PDF pages.
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/sfneal/PyPDF3
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/sfneal/PyPDF3/archive/1.0.3.tar.gz
+ sha256sums = 9ddd09afb7c1749609523b6c4fd705a503d40984b4c098938adaf20f975a9548
+
+pkgname = python-pypdf3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f12f8cfb7002
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess DOT mn>
+
+pkgname=python-pypdf3
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Pure-Python PDF library for splitting, merging, cropping, and transforming PDF pages."
+arch=('any')
+url="https://github.com/sfneal/PyPDF3"
+license=('custom')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/sfneal/PyPDF3/archive/${pkgver}.tar.gz")
+sha256sums=('9ddd09afb7c1749609523b6c4fd705a503d40984b4c098938adaf20f975a9548')
+
+build() {
+ cd ${srcdir}/PyPDF3-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/PyPDF3-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}