summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Tam2020-08-13 02:22:27 +0800
committerChris Tam2020-08-13 02:22:27 +0800
commit5152849c1ed1b233d7db3b44007b28461c0899a2 (patch)
tree1594eeb5686e362197750c6a3fcdd493102a6d82
downloadaur-5152849c1ed1b233d7db3b44007b28461c0899a2.tar.gz
Initial
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD43
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d845e362d913
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-pyperclip-git
+ pkgdesc = A cross-platform clipboard module for Python (git)
+ pkgver = r197.d72f3ce
+ pkgrel = 1
+ url = https://github.com/asweigart/pyperclip
+ arch = any
+ license = BSD
+ checkdepends = xorg-server-xvfb
+ checkdepends = python-pytest
+ checkdepends = xsel
+ checkdepends = xclip
+ makedepends = python-setuptools
+ depends = python
+ optdepends = xclip: xclip backend
+ optdepends = xsel: xsel backend
+ optdepends = plasma-workspace: klipper backend
+ provides = python-pyperclip
+ conflicts = python-pyperclip
+ source = pyperclip::git+https://github.com/asweigart/pyperclip.git
+ sha512sums = SKIP
+
+pkgname = python-pyperclip-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ada30869995e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pyperclip/
+python-pyperclip-git-*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8034649b0d6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chris Tam <LChris314 at gmail dot com>
+
+pkgname=python-pyperclip-git
+pkgver=r197.d72f3ce
+pkgrel=1
+pkgdesc="A cross-platform clipboard module for Python (git)"
+arch=('any')
+url="https://github.com/asweigart/pyperclip"
+license=('BSD')
+makedepends=('python-setuptools')
+# GTK/Qt tests crash xvfb, and Klipper tests require a running klipper
+checkdepends=('xorg-server-xvfb' 'python-pytest' 'xsel' 'xclip')
+depends=('python')
+optdepends=('xclip: xclip backend'
+ 'xsel: xsel backend'
+ 'plasma-workspace: klipper backend')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("pyperclip::git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd pyperclip
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd pyperclip
+ python setup.py build
+}
+
+check() {
+ cd pyperclip
+ PYTHONPATH="${PWD}/build/lib:${PYTHONPATH}" xvfb-run py.test
+}
+
+package() {
+ cd pyperclip
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE.txt"
+}
+
+# vim:set ts=2 sw=2 et: