summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-03-18 15:39:48 +0100
committerMartino Pilia2018-03-18 15:39:48 +0100
commit51c58e7cf2f4da8e3ce0354953d08c8d125f121f (patch)
tree00ce849388ac4eee7ae047973d57382a1b41ba6d
downloadaur-51c58e7cf2f4da8e3ce0354953d08c8d125f121f.tar.gz
create package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4fd19f7af91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pypi2pkgbuild-git
+ pkgdesc = Convert PyPI packages to Arch Linux packages
+ pkgver = 0.1.r26.g2c0e9c5
+ pkgrel = 1
+ url = https://github.com/anntzer/pypi2pkgbuild
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python-pip
+ depends = namcap
+ depends = pkgfile
+ conflicts = python-pypi2pkgbuild
+ source = git+https://github.com/anntzer/pypi2pkgbuild.git
+ sha512sums = SKIP
+
+pkgname = python-pypi2pkgbuild-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86ed159354a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=pypi2pkgbuild
+pkgname=python-$_pkgname-git
+pkgver=0.1.r26.g2c0e9c5
+pkgrel=1
+pkgdesc="Convert PyPI packages to Arch Linux packages"
+arch=('any')
+url="https://github.com/anntzer/pypi2pkgbuild"
+license=('MIT')
+depends=('python-pip' 'namcap' 'pkgfile')
+makedepends=('python-setuptools' 'git')
+conflicts=('python-pypi2pkgbuild')
+source=("git+https://github.com/anntzer/pypi2pkgbuild.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | \
+ sed 's/^v//;s/_/./;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --optimize=1 --root="$pkgdir"
+}