summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien Dubosson2016-11-09 12:06:10 +0100
committerFabien Dubosson2016-11-09 12:09:23 +0100
commit73b30b1b0ab8bb42948c729b0f47510dffe8e407 (patch)
treeccaced5e57d8efdcaf4d7d7fa24278e977b791b3
downloadaur-73b30b1b0ab8bb42948c729b0f47510dffe8e407.tar.gz
Package created
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore8
-rw-r--r--ChangeLog4
-rw-r--r--PKGBUILD25
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..619cc9b892fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Nov 9 11:08:40 UTC 2016
+pkgbase = python-pypillowfight
+ pkgdesc = Library containing various image processing algorithms
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/jflesch/libpillowfight
+ changelog = ChangeLog
+ arch = any
+ license = GPL3
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/jflesch/pypillowfight/archive/0.2.1.tar.gz
+ md5sums = cf372a544d90d3cf29f3ec89fa3ebee5
+
+pkgname = python-pypillowfight
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e6c93286c06
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Downloaded and generated files
+*.log
+*.tar
+*.tar.xz
+*.tar.gz
+
+# All sub-folders
+*/
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..86c3223daeec
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,4 @@
+2016-11-09 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * v0.2.1-1:
+ Package created
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..555023d5ad1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Fabien Dubosson <fabien.dubosson@gmail.com>
+
+pkgname="python-pypillowfight"
+_pkgname="pypillowfight"
+pkgver="0.2.1"
+pkgrel="1"
+pkgdesc="Library containing various image processing algorithms"
+url="https://github.com/jflesch/libpillowfight"
+depends=('python' )
+makedepends=('python' 'python-setuptools')
+license=('GPL3')
+arch=('any')
+changelog="ChangeLog"
+source=("https://github.com/jflesch/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('cf372a544d90d3cf29f3ec89fa3ebee5')
+
+build() {
+ cd ${srcdir}/libpillowfight-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/libpillowfight-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1
+}