summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien Dubosson2018-03-06 16:59:54 +0100
committerFabien Dubosson2018-03-06 19:18:55 +0100
commit9cd7aa4bc67292cdceaef3561c2b34858ecaf712 (patch)
treeea1ce6ee275c1ff752f9ea343417176d0cafa7c8
parent6e33597ac9e2baab2e2b310e941217a4b5839b21 (diff)
downloadaur-9cd7aa4bc67292cdceaef3561c2b34858ecaf712.tar.gz
New upstream realease 0.2.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcb587eff0f0..e2d5b5964c37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Mar 3 19:21:51 UTC 2018
+# Tue Mar 6 15:59:25 UTC 2018
pkgbase = python-pypillowfight
pkgdesc = Library containing various image processing algorithms
pkgver = 0.2.3
@@ -10,9 +10,10 @@ pkgbase = python-pypillowfight
license = GPL3
makedepends = python
makedepends = python-setuptools
+ makedepends = git
depends = python
- source = https://github.com/jflesch/pypillowfight/archive/0.2.3.tar.gz
- md5sums = 50d3837c227b6153d34b826c0a940809
+ source = git+https://github.com/jflesch/pypillowfight#tag=0.2.3
+ md5sums = SKIP
pkgname = python-pypillowfight
diff --git a/PKGBUILD b/PKGBUILD
index a2abf6f16676..cf95a8393653 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,19 @@ pkgrel="1"
pkgdesc="Library containing various image processing algorithms"
url="https://github.com/jflesch/libpillowfight"
depends=('python' )
-makedepends=('python' 'python-setuptools')
+makedepends=('python' 'python-setuptools' 'git')
license=('GPL3')
arch=('any')
changelog="ChangeLog"
-source=("https://github.com/jflesch/${_pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('50d3837c227b6153d34b826c0a940809')
+source=("git+https://github.com/jflesch/${_pkgname}#tag=${pkgver}")
+md5sums=('SKIP')
build() {
- cd ${srcdir}/libpillowfight-${pkgver}
- make version
- python setup.py build
+ cd ${srcdir}/${_pkgname}
+ make build
}
package() {
- cd ${srcdir}/libpillowfight-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1
+ cd ${srcdir}/${_pkgname}
+ PIP_ARGS="--root=\"${pkgdir}\" --optimize=1" make install_py
}