summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2016-08-15 10:36:45 +0200
committerMassimiliano Torromeo2016-08-15 10:36:45 +0200
commit123d70188b819d0e898bc9cef7e31da629fabdda (patch)
tree9f2340e60a766d147aed89a8807852781e5f4d9f
downloadaur-123d70188b819d0e898bc9cef7e31da629fabdda.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD24
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad94b2e7098b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Aug 14 18:21:00 UTC 2016
+pkgbase = python-pypng
+ pkgdesc = Pure Python library for PNG image encoding/decoding
+ pkgver = 0.0.18
+ pkgrel = 1
+ url = https://github.com/drj11/pypng
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-six
+ source = https://github.com/drj11/pypng/archive/pypng-0.0.18.tar.gz
+ sha256sums = 6daa52c8b36c51acd86218353a7147692ade70ba2f25b124fbc56ffe3b8ca4df
+
+pkgname = python-pypng
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6fda8506d38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=python-pypng
+pkgver=0.0.18
+pkgrel=1
+pkgdesc="Pure Python library for PNG image encoding/decoding"
+arch=(any)
+url="https://github.com/drj11/pypng"
+license=('MIT')
+depends=('python-requests' 'python-six')
+makedepends=('python-setuptools')
+source=("$url/archive/pypng-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir"/pypng-pypng-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/pypng-pypng-$pkgver
+ python setup.py install -O1 --skip-build --root="$pkgdir"
+}
+
+sha256sums=('6daa52c8b36c51acd86218353a7147692ade70ba2f25b124fbc56ffe3b8ca4df')