summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-12-28 22:06:18 -0500
committerCarlos Aznarán Laos2021-12-28 22:06:18 -0500
commitb32420468e51befb1e2b42d7f20f914158fba476 (patch)
tree1c03e0671278ccf43750917fe535512435fe17ec
downloadaur-b32420468e51befb1e2b42d7f20f914158fba476.tar.gz
Version bump to 2.3.0.1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d379a00d8fdd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyprecice
+ pkgdesc = Python language bindings for the preCICE coupling library
+ pkgver = 2.3.0.1
+ pkgrel = 1
+ url = https://github.com/precice/python-bindings
+ arch = x86_64
+ license = LGPL3
+ checkdepends = python-argparse
+ makedepends = python-setuptools
+ makedepends = cython
+ depends = precice
+ depends = python-mpi4py
+ source = https://github.com/precice/python-bindings/archive/v2.3.0.1.tar.gz
+ sha512sums = 0b0447a9cb9989ae5035919439f3e73401dab2a4cda49d298a10f55842c197239c1d43ca6271ddbf5ef03bda4cf075020c18142a6d4c6d26103f75d332cba822
+
+pkgname = python-pyprecice
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..691a69f4f5c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=pyprecice
+pkgname=python-${_base}
+pkgdesc="Python language bindings for the preCICE coupling library"
+pkgver=2.3.0.1
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/${_base/py/}/python-bindings"
+license=(LGPL3)
+depends=(precice python-mpi4py)
+makedepends=(python-setuptools cython)
+checkdepends=(python-argparse)
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('0b0447a9cb9989ae5035919439f3e73401dab2a4cda49d298a10f55842c197239c1d43ca6271ddbf5ef03bda4cf075020c18142a6d4c6d26103f75d332cba822')
+
+build() {
+ cd "python-bindings-${pkgver}"
+ python setup.py clean --all
+ python setup.py \
+ build_ext \
+ --include-dirs=/usr/include \
+ --library-dirs=/usr/lib \
+ --inplace
+}
+
+check() {
+ cd "python-bindings-${pkgver}"
+ # https://github.com/precice/python-bindings/issues/1
+ python setup.py test
+}
+
+package() {
+ cd "python-bindings-${pkgver}"
+ export PYTHONHASHSEED=0
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}