summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-06-19 19:31:44 -0500
committerCarlos Aznarán Laos2022-06-19 19:31:44 -0500
commitddd60f4c2ec8c0576304d5a0316f4db986cc8d07 (patch)
tree6f437e055b41372bce9a7e4fa7f003af678ac9c2
parentcd26908bb0ae5876c15e14b3be4a4ba40a947be8 (diff)
downloadaur-ddd60f4c2ec8c0576304d5a0316f4db986cc8d07.tar.gz
Add openssh as checkdependency for pass the tests, according to open-mpi/ompi/issues/3625
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e86ca326c1a6..ea16f5b7a76b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-pyprecice
pkgdesc = Python language bindings for the preCICE coupling library
pkgver = 2.4.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/precice/python-bindings
arch = x86_64
license = LGPL3
+ checkdepends = openssh
makedepends = python-setuptools
makedepends = cython
depends = precice
diff --git a/PKGBUILD b/PKGBUILD
index 7eb94bcd688f..ed960302393d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,13 @@ _base=pyprecice
pkgname=python-${_base}
pkgdesc="Python language bindings for the preCICE coupling library"
pkgver=2.4.0.0
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="https://github.com/${_base/py/}/python-bindings"
license=(LGPL3)
depends=(precice python-mpi4py)
makedepends=(python-setuptools cython)
+checkdepends=(openssh)
source=(python-bindings-${pkgver}::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('c4001e676e623d299f9be214b1f04d95497e93fed1d68a1bf3ac1d12cd154fc6c6186c7918ebb7e5ebb73de57f783e9d9509a5b23ad42e8562aecec2925d413c')
@@ -24,6 +25,9 @@ build() {
}
check() {
+ if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
+ export OMPI_MCA_opal_warn_on_missing_libcuda=0
+ fi
cd python-bindings-"${pkgver}"
# https://github.com/precice/python-bindings/issues/1
python setup.py test